Quantcast
Jump to content

UTV Ride Reports - Where to Ride

Sign in to follow this  

Report your UTV rides here. Please post as much information, location, pictures, etc..as you can. Post Riding area inquiries. Find out where to ride that UTV!

53 topics in this forum

    • 2 replies
    • 2,755 views
    • 4 replies
    • 362 views
    • 1 reply
    • 1,354 views
  1. eastern united states

    • 0 replies
    • 1,362 views
  2. washing state

    • 0 replies
    • 1,276 views
    • 0 replies
    • 2,037 views
  3. Glamis trip

    • 0 replies
    • 961 views
    • 3 replies
    • 3,021 views
  4. Baja

    • 0 replies
    • 1,766 views
    • 0 replies
    • 1,676 views
    • 0 replies
    • 1,698 views
    • 0 replies
    • 1,569 views
    • 0 replies
    • 2,194 views
  5. Summer 2012 Trooper Trip

    • 1 reply
    • 1,821 views
    • 0 replies
    • 1,678 views
    • 8 replies
    • 2,809 views
    • 1 reply
    • 1,829 views
  6. Summer 2012

    • 0 replies
    • 1,537 views
    • 0 replies
    • 1,725 views
  7. More Camping in Utah

    • 0 replies
    • 1,936 views
  8. arizona trails

    • 2 replies
    • 3,351 views
    • 0 replies
    • 1,813 views
  9. Baja Trip Report

    • 0 replies
    • 1,535 views
    • 0 replies
    • 3,162 views
    • 0 replies
    • 2,422 views
Sign in to follow this  
  • Latest Posts

    • Anyone know where i can get headers bought or made for my 800cc F8b?  I’ve seen some older posts where guys were making/selling them. Or does anyone have some you’d like to sell me? thx
    • I just finished rebuilding my 800cc SOHC f8b and boy did I wake this little engine up with port, polish , exhaust, cam and valves! I’ve richened up my stock carb about as far as it will go and still seems to be running on the lean side especially under hard acceleration. I’ve read some posts and going to try my hands at a weber 32/36 two questions: 1- Is this the best upgrade carb for the engine?  2- Will it fit with stock manifold? I ordered the Suzuki Samuri  conversion kit with carb...
    • Old thread, but for new readers, you need to buy a battery isolator, which is just two diodes mounter on a heat sink.
    • Thanks for the tips Aussie1. The choke cable appears to be working fine, although I have not measured cable movement to ensure it is within specs.  The machine is ten years old, but it has only 600 kms on it. I suppose I could check valve clearances, but I haven't largely because of the low mileage, and because it goes from running fine to flaming out. When you start it back up, it runs fine at idle as well at higher RPMs. However, once you let it idle again for a few seconds, it begins to pop a bit and then stalls.  If the valves required adjustment, I imagine the problem would be more consistent. I still suspect either a potential problem with the fuel delivery (I have a new pump on its way), or a faulty ignition coil. I guess I'll see if the problem is resolved once both parts are replaced. 
×