Quantcast
Jump to content

New Members Area

Are you a new member to UTVBoard.com? Stop by here and introduce yourself. Tell us about yourself, your vehicle, etc.

156 topics in this forum

    • 2 replies
    • 1,278 views
    • 0 replies
    • 876 views
    • 0 replies
    • 956 views
    • 1 reply
    • 1,980 views
  1. new UTV owner

    • 5 replies
    • 2,558 views
  2. hello

    • 2 replies
    • 1,341 views
    • 4 replies
    • 1,586 views
  3. Hello all.

    • 3 replies
    • 1,355 views
  4. Hello to all

    • 8 replies
    • 1,990 views
  5. Hi Mopartist!

    • 1 reply
    • 965 views
  6. Attention All New Members

    • 2 replies
    • 1,611 views
  7. Welcome 07turbo

    • 0 replies
    • 859 views
  8. Hey All!

    • 25 replies
    • 4,078 views
  9. Hey all

    • 7 replies
    • 1,749 views
  10. Member Profile

    • 0 replies
    • 1,001 views
  11. Hello to everyone

    • 8 replies
    • 2,173 views
    • 4 replies
    • 1,634 views
  12. New to Site

    • 5 replies
    • 1,592 views
  13. Anylizer

    • 3 replies
    • 1,212 views
    • 5 replies
    • 1,492 views
  14. Flatbed

    • 2 replies
    • 1,414 views
  15. Hi from North Dakota

    • 3 replies
    • 1,182 views
    • 2 replies
    • 1,109 views
  16. G'day from NZ

    • 1 reply
    • 982 views
    • 1 reply
    • 1,595 views


  • Latest Posts

    • Travis, some of the Kawasaki engines are really great and long lived. I have their 2 cylinder engine on a Ferris Zero turn mower, water cooled version. 26 HP don't remember the displacement but it's 13 years old now with 2105 hours on it. So far no problems and I should not say that because now it will explode. Anyway, changing oil and filter every 50 to 75 hours over its life I'm sure has contributed to its longevity. Putting in new spark plugs every year or 2 helps with the starting. I should check the valve adjustment too but will try to remember to get to that this winter.  GC
    • I have my 550 torn apart now rebuilding the engine. Luckily it's a single cylinder. Ran good for 17 years and rings started to go. just did regular maintenance.
    • If you own a 4000 or 4010 Mule, and perhaps others that are of the 2cylinder type, there is an ignition -coil for each cylinder. When one of them dies, and they must because there seem to be a lot of them sold through the internet and that coil is used on several makes of engines, then your DFI light will not go out after the engine is started which indicates that you have a problem. If it's the coil then you are running on one cylinder and the power you now have is enough to get you back home, the limp home mode.  The # 1 coil is the one in front and isn't bad to get to but the #2 coil is the one in the rear and next to impossible to get to. If you read the manual it tells you how many things you must take apart to get to it Trust me, You have a lot to disassemble, Tire, shock absorber, torque converter housing , clutch, starter motor, and then the coil. I figured out how to eliminate that but you need patience , a lot of swear words, a lot of luck, and a special 8 mm wrench..  Pray yours doesn't die and if so you may want to take it to a dealer and let them fix it.  Gerry C
    • Glad you got it figured out! how come the coil needs replaced?
    • Might doesn't make right but it beats whatever's in 2nd place. I think my folks did spend their money on my education wisely. It taught me to think. My idea of spreading open the bracket that holds the pin was correct. Why the parts diagram doesn't show the connecting pin separately is because it is part of the cable and not a separate part. For those of you who had the same problem as I trying to replace the hood release cable, the bracket which is a welded part of the release latch mechanism is like a square "U" with a hole drilled through it to accept the pin. On one side of the bracket is a slot about a 1/4 inch wide from the outside edge to the hole. Take a large screw driver or or wedge and twist the slot until it opens up just enough to release the pin and the cable. Now you can pull the cable, knob and all out through the hole in the dash. This, assuming you've managed to release the nut holding the whole thing tight against the bracket that the cable goes through. That bracket also has a slot cut through it and as you pull the cable through you may be able to slide the cable out through the slot or maybe even bend it enough to get the cable out. It's a thick bracket so you may not be able to bend it. Haven't gotten that far as yet. Will work on that tomorrow. I'll let you know how that works out and the steps necessary to replace it. After that, if anyone is interested, I'll go through another nightmare and that is replacing the ignition -coil in the rear or #2 spot on the Mule. That's a bunch of fun too. Gerry C


×