Quantcast
Jump to content

MegZ

Happy Thanksgiving!

Recommended Posts

I do stuff like that all the time. Really hate it when it is on a site/blog where I can edit my mess-up.

rocmoc n AZ/Mexico

Share this post


Link to post
Share on other sites


Happy Thanksgiving!

* Merged all the Thanksgiving threads into one topic. :rolleyes:

Share this post


Link to post
Share on other sites

Happy Thanksgiving to you and your's Alex.

Thankful for the UTV Board 👍

Gobble gobble

  • Like 1

Share this post


Link to post
Share on other sites

Happy Thanksgiving.  Pretty crappy day for us but looking at the weather channel it is still the BEST in the States.  So I guess we are very lucky.  Rode twice last week and going out again next week, Monday or Tues.  ENJOY!

rocmoc n AZ/Baja

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Travis
      The cables are sort of seized up on the emergency brake, they still work but i have to wiggle and pull on em to get them to release, i pulled the drum off but cant see a way to remove the cable. It is kind of dirty inside the drum where it was leaking so i need to run to the parts store and buy some parts cleaner so i can see everything better.
       The shop manual i have  does not cover parking brake cable removal, well.... it does kind of. it says "Remove parking brake cable at both ends" 🙄
       We'll see
       EDIT: ARRR! Looks like my rear axle seal is leaking, there is a small puddle on a machined step below the seal and it smells like Trans oil. felt around the wheel cylinder and it isn't coming from their.....  I guess my weekend is planned for me LOL
    • By Travis
      Happy Independence day!! HAPPY 231ST America!
      GOD BLESS THE USA!
    • By Travis
      They got in a day late,  but no more unsightly cracks!   In the seat, i mean  :D    


    • By Damage442
      I have a 1100cc T/2 that I am replacing all of the propeller shafts, ball joints, tie-rod ends etc.. I am also going to relocate the Radiator, air filter and exhaust for mudding.
      parts I need 
      2 front propeller shafts/ Axles
      Front and rear Hub Bearing kits
      Starter
      Mud flares for fenders
      Roof/half doors
       
    • By Terrypenton
      All Gage's except the speedometer and tachometer.  I do understand that these two Gage's are fed from the computer and the rest from sending units.  For the engine oil pressure, engine temperature, alternator, and fuel Gage's, I have checked fuses, sending units and wiring harnesses for loose or broken wires, and have even changed out one of the Gage's but nothing has changed.  I have read forums and have not been able to gather any information to assist me.  Any information or suggestions will be greatly appreciated.


×
×
  • Create New...