Quantcast
Jump to content

Sign in to follow this  
avarner

2005 Suzuki Hayabusa GSX 1300R

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Robbie Wyre
      I'm working on a 2005 Cub Cadet side by side and I'm trying to remove the front two axles.  I have a slide hammer puller on the inner joint and with all my strength they will not budge.   Anyone have the same issues and is there something I'm missing or a trick of some sort to pull these out?   Any suggestions please and thank you.
    • By Karla Phelps
      A arm bushings needed for a 650 Joyner 2005
    • By Birddog1148
      Well after a good buddy of mine shared how happy he was with a Massimo 500 I decided to pull the trigger on one of my own.  Probably the main use will be dirt roads and trails near Baldwin Mi where I have a camp.  But my town does allow them to be plated and driven on the road.    Hope my experience is as good as my buddy's is.  Behind it there is a 400 King quad that you cant see and a 86 CJ7 project and my 69 Baja bug.

    • By Neil Wilson
      I just bought a 2008 Trooper T2 not knowing much about them. On this one the owner said the horn doesn't work, the winch never did work and during inspection the rear brake lights didn't work. He said he replaced the rear light pods recently and the brake lights worked before. He said the fuse module is corroded so he bypassed it and rigged up his own switches for the fuel pump and radiator fan. I see in the wiring diagram the horn and rear brake lights are on the same circuit. Now I am worried the problem is in the wiring harness.
      I have the wiring diagram from the online manual but I can't make any sense of it. I see lots of posts about wiring issues and I am feeling a bit overwhelmed with all the issues I see with these machines and am regretting buying it.
      For now my main concern is to get the brake lights working so I can drive it to some nearby trails. I would appreciate any advice on how to go about diagnosing the problem or workarounds. Also if there is a better wiring diagram out there that might help. I would consider hiring someone local to diagnose it so any recommendations are welcome.
      TIA.
    • By Drake
      As an ATV owner (old one BTW), I often come across a search for various owner's manuals, service guides, parts manuals, etc. Therefore I shurely understand how hard it could be to find suitable manuals. Therefore, I present to your attention a website that contains various instructions for ATVs from top brands: https://www.ATVownersmanual.com
      Currently only 3 manufacturers are represented here: Can-Am, Polaris, Yamaha - and only about 1200 instructions for various models. Very soon other brands and manuals will be added.
      Main pros of the website: all files are in PDF and downloadable so you can use offline. Navigation structured by brand, year and model. There is no advertising yet.
      I am happy to hear criticism and recommendations. If you have missing or rare instructions, send them to PM or to the website's email: info [...at...] atvownersmanual [...dot...] com.


×
×
  • Create New...