Quantcast
Jump to content

  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Blaze379
      I am installing a second battery in my 07 Prowler. How do I wire it up so the stereo doesn't drain the main battery, but the second battery can still charge
    • By Biggz
      My family moved from Illinois to Leadville Colorado about 3 months ago.  Leadville has a lot of trails to ride and some fun off road stuff  that i would love to start getting into with my boys. I currently have a 04 HD FXD Superglide that i might sell or trade for a UTV. My question is are there any UTV that are good solid used side by side that i could find for about $4500 or $5000? If not I will keep saving for something. If so what brand and year should i be looking for? Thank you for your help!!
       
      Thank you
      Chris
    • By Thomas Mohr
      I would like to replace the stock battery on my 2007 Mule 3010 with a larger battery. I am wondering if any other electrical system modifications are necessary? Will the stock charging system supply enough current to keep the battery charged? The only accessories I have added are a KFI winch and a Cycle Country power bed lift.
    • By Doc Holland
      I noticed the battery post was melted when the pug wouldn't start... With the pug off, just placing the cable back onto the battery creates tremendous Heat with in 5 seconds or so... I had just taken off all the connections and clean them with a wire brush just a few months back...Including battery cables and wires for the starter solenoid. 
      Could this only be a short or bad connection or is there something else?..could the cells of the battery be doing this or maybe the rectifier/regulator? The rectifier from visual inspection doesn't seem to be melted or discolored!
    • By SPF4524
      Troubleshooting Kubota 400.  it  is tough to start, I have to pump the gas pedal. After it starts it will idle, but bogs down and backfires when I  give it gas. I've replaced the fuel pump and it did not fix the problem. Any other suggestions that would not require replacing throttle body and ECU ?


×
×
  • Create New...