Quantcast
Jump to content

Recommended Posts

2017 msu500 efi. Has spark and fuel. Valves are within clearances.  Leave key on I get a 118 code. Ect sensor? Could this keep it from starting

Old plug was black

Share this post


Link to post
Share on other sites

Looks like blown head gasket.  Temp light came on and started shooting water out exhaust . Should be under warranty  only 25 hrs on it

  • Like 1

Share this post


Link to post
Share on other sites

Ordered from motorcycle doctor. Put new gaskets in everything back together and fired right up. But saw bubbles between head and hug. Gonna take back apart and try resurfacing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • 2009 Joyner trooper starting problems

      I have a no cranking issue with my joyner. It has a chery 1100. It will click but nothing after that.  New battery. I tried banging in the starter while holding key in start(old car trick). Now the  starter solenoid won't even clunk. Just hear s click fron the relay now.  My assumption is the starter needs replacing.  Any ideas of other things to check? Does anyone have diese block diagrams?  Got no clue what fuse or relay goes to what

      By Whisper Snowbird, in Joyner UTV SxS Forum

      • 12 replies
      • 107 views
    • Starting a shop for Joyners

      We would like to add a repair and parts shop to our shop in Southern  California for the Joyners. How many Joyner people in the area do we have that own Joyners? 

      By WCF, in Joyner UTV SxS Forum

      • 24 replies
      • 522 views
    • Slow 2017 HiSun Strike 250

      Guys, I need some expert help..  I just bought a 2017 HiSUN Strike 250 and was real disappointed to find out that there is an electronic spark cut out at 30 mph.  Every article that I read prior to purchase said that the unit could hit 45-50 mph with the pedal stop screw removed.  Not the case with my machine.  Never bothered to ask the dealer before purchase, so it is my fault...  My guess is that HiSun got some flack about thier "kids" machine doing 50 mph and were forced to add the electronic limiter..  Can anyone verify that previous to the 2017 model that the machine can actually could do 45-50mph with the just pedal screw removed?  If so, what RPM is it at when doing 45-50 mph.  Maybe I can get an older version of the Delphi ECU, assuming that is where the spark cut out is located...? The machine is definitly full featured, but as you all mention, needs to be gone over after purchase.  A-men to stipped screws, and if you suffer from a crazy squeak sound that sounds like chains dragging, check the torque on the suspension a-arms and shocks.  Ours were so tight, we could barley get them loose and the suspension would not move, essentially zero travel.  Once we lightened up the torque, greased the plastic bushings, and added blue threadlocker, the suspension actually worked and all the squeaks went away.  Also have same problem with the shift linkage rubbing on pipe and also pipe rubbing on chassis.. This weeks project! Any help on the speed would be awesome!

      By Fun Dad, in Hisun UTV SxS Forum

      • 42 replies
      • 3,227 views
      • 3 replies
      • 200 views
    • 2015 Massimo 1000 dying and not starting

      It will run great for a day or so, then it will randomly die, sometimes starting right back up, sometimes not.  Other times it just won't start at all for a couple days then fire right up the next time.  I have drained the gas, refilled with fresh gas, changed the spark plugs, and replaced the entire air filter.  Besides buying a new fuel pump to try, is there anything else someone can suggest.  

      By xkatrik, in UTV General Discussion

      • 2 replies
      • 390 views
×