Quantcast
Jump to content

marypippin14

kaf620-e3 kawasaki mule side by side

Recommended Posts

Hey all my mule runs great until it gets hot then  just quits. won't start back have to plug battery in to charge it up seems like the  battery doesn't recharge when it is running.

Share this post


Link to post
Share on other sites


likely your generator (alternator) is charging right or not at all.

Does it make any noises when you try to start it after quits?

 

Share this post


Link to post
Share on other sites

The clicking sound is the starter solenoid, It clicks when i tries to engage, but doesn't have enough power to get it to engage.

 I  think i would start by doing the cheaper fix first, the battery.  It could be damaged and not charging  right.

https://www.batteriesplus.com/battery/utility-vehicle/kawasaki/kaf950-mule-3010-diesel-4x4/950cc

 

Share this post


Link to post
Share on other sites

Measure the voltage at the battery with the engine running at about 1500 RPM.  If over about 14 volts, your alternator is good.  If not, then suspect the alternator.  If you have the time, charge the battery and let is sit for 24 hrs.  If not at 12.6 vdc after that time, your battery can't hold a charge.  You don't want to shotgun parts replacement - it can get expensive if your shotgun is off target.

  • Like 1

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Second Battery

      I am installing a second battery in my 07 Prowler. How do I wire it up so the stereo doesn't drain the main battery, but the second battery can still charge

      By Blaze379, in Arctic Cat UTV SxS Forum

      • 5 replies
      • 3,840 views
    • Kawasaki Mule 3010 battery

      I would like to replace the stock battery on my 2007 Mule 3010 with a larger battery. I am wondering if any other electrical system modifications are necessary? Will the stock charging system supply enough current to keep the battery charged? The only accessories I have added are a KFI winch and a Cycle Country power bed lift.

      By Thomas Mohr, in Kawasaki UTV SxS Forum

      • 3 replies
      • 179 views
    • Massimo no start

      2017 msu500 efi. Has spark and fuel. Valves are within clearances.  Leave key on I get a 118 code. Ect sensor? Could this keep it from starting Old plug was black

      By Swampdonkey, in Massimo UTV SxS Forum

      • 10 replies
      • 1,167 views
    • Pug battery post melted

      I noticed the battery post was melted when the pug wouldn't start... With the pug off, just placing the cable back onto the battery creates tremendous Heat with in 5 seconds or so... I had just taken off all the connections and clean them with a wire brush just a few months back...Including battery cables and wires for the starter solenoid.  Could this only be a short or bad connection or is there something else?..could the cells of the battery be doing this or maybe the rectifier/regulator? The rectifier from visual inspection doesn't seem to be melted or discolored!

      By Doc Holland, in UTV General Discussion

      • 1 reply
      • 203 views
    • hisun 800 intake backfire/no start

      I am working on a friends hisun 800. he said whenever you transport it on a trailer it takes forever to start and he has to floor it to get it to start. he also said it wouldn't go over 30mph like it was being held back. I get it to my house try to start it and all im getting is backfire through intake. I checked spark it was good. I know its a no no but I sprayed a small shot of starting fluid in airbox to see if it would start and it backfired and lit the fluid on fire. currently I am wondering if the valves may be out of adjustment anybody have any suggestions or help would be greatly appreciated.

      By huey224, in Hisun UTV SxS Forum

      • 2 replies
      • 261 views


×