Quantcast
Jump to content

Glock_King

RTV 1100 / AC fuse keeps blowing

Recommended Posts

 AC blows cold for while ... meter shows 2amps then all of a sudden spikes and blows fuse ... and not necessarily when AC clutch engages .... 2012 model with only 126 hours ....  any ideas ?

Share this post


Link to post
Share on other sites


I can only suggest you trace the wiring from the fuse to the blower motor and clutch.  Could be an intermittent dead short to ground in the wiring or blower motor.  Disconnect the blower motor to see if the fuse holds.  If it does, the blower motor is suspect.  Otherwise, the wiring.  Do the same for the clutch just in case it is in the clutch.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Beetle1
      2012 hisun 700 efi front runner  turns over hard and the valves don't move and no compression  any ideas on what could be wrong with it ???? Thanks in advance 
    • By Texjpr
      2002 ranger 500 4x4 stopped running and wouldn't restart. Service manual wiring diagram helped identify the hub safety switch as the culprit. Using jumper wires to bypass  switch allowed the engine to start and run normally. Inspection of switch showed melted epoxy and a strong smell of burnt electrical. Unable to find replacement part either used or new. Is there a work around other than jumper wiring?
    • By Cub owner
      Ok trying again... I have 2018 cub cadet 750. Having clutch issues. Has anyone bought a upgrade for them and where did you get them and about how much. Thanks for any help given. From what i have looked over on here. Lots of nice helpful people 
    • By Joel Neubecker
      I just bought a 2008 Prowler 650 H1.  Rode it about 20 miles and the belt absolutely exploded!  Long story short, while replacing the belt, I spread the secondary with the cover bolt and didn't take it out before I put the secondary back on.  I tried to remove the bolt after I tightened the nut and it snapped off still stuck in the spreader hole.  I have no idea what to do.  Any help or suggestions would help greatly.  Thanks.


×
×
  • Create New...