Quantcast
Jump to content

  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By OlEd
      Head gasket replacement, what’s a top quality head gasket to use? Should a person stud the head? Where would I find a place that sells both? Thank you for any info. 
    • By OlEd
      Hisun 500 having overheating problem after water pump install. Should  engine have a thermostat ? Has a thermostat housing but no stat, parts diagram showed it doesn’t. If it does where would I get one if Hisun doesn’t offer?
    • By Utv51
      Hello hisun owners! I love my utv.
      but as well other utv types mine needs some help from time to time.
      the voltage regulator fried  a pin hole on the plug it goes into. There are 6 pins on voltage regular so I am trying to find the plug that it connects to. No luck online.  Called Coleman company and waiting for help to replace plug. 
      Anyone have a clue where I can buy a new plug?  I use my utv for several projects and need this fixed fast! 
      Thank you for any helpful replies.  
       
    • By strike250
      Hey there, new member here, just looking for information and tips. I just purchased a Hisun strike 250 for my young son. We have taken it to elsinore mx park here in so cal and he had a blast. I know I am going to get a lot of feedback regarding this, but I have to tell you, for the money, and his age, I can't complain. It always starts, is a blast to ride, and yes, I can fit in it at 6.1 and 195lbs. Have we had any issues? sure, but about the same about as any other vehicle, so I can't really complain. We couldnt find any aftermarket parts for it, so we engineered our own 2 inch lift kit for it, and it worked great. We have mounted additional lights on it as well. Some of the things we did notice are that the shift linkage seemed to be rubbing the exhaust pipe, and so I modified the shift linkage, and now that problem is gone. I also noticed that the factory plastic is very brittle, meaning it will crack if not handled properly. The quality of the OEM nuts and bolts are very poor, they seem to strip out very easy. So, we are replacing what ever bolt we remove, with a higher quality version. The battery is not easy to access, and in a pinch, that could be a problem, as tools are required to get to the battery. If you were to need a jump out in the boonies, you might be stuck. Also, the factory 4 point harness is hard to adjust, so we might have to replace them with aftermarket versions. Aside from that, he has not really had any problems with it. Granted it is not a larger 500 or 900cc UTV, so the load and demands on it are less. I do wish it had more power, but since he's only 9, I am good for now lol. It never quit on us, ran great in 106 degree heat, and handled the muddy track with ease. Another plus, it fits in the back of my truck bed with the tailgate up lol. Just my 2 cents.

    • By etimc
      I suspect I have a faulty temp sensor but at the cost of the sensor plus 50 percent tariff plus the shipping cost to Costa Rica, i would like to confirm it - the Hisun 800 has 2 sensors - one in the radiator appears to be a fully open or fully closed bi-metal contact switch similar to the old household thermostats for your heating system. - My fans turn on and off automatically as they should and a jumper across the connector also triggers the fan - appears to be a simple logic circuit back to the computer that then trips a relay for the fans.  The second sensor is on the back cylinder almost hidden by the throttle body and idle control system - I have unplugged it, sprayed it with contact cleaner, checked the pins, tried to get a resistance reading across the sensor, reconnected it and still get a blinking red light on the display panel warning of high temperature - this occurs even when the buggy is still cold having just started it in the morning - I have not been able to trace out the other end of the cable on the display panel since it appears i will have to remove the entire front plastic to get to it - hoping i could confirm the resistance before i go to that step (this is the same buggy originally posted by Jim Magnuson last September when the spark arrestor overheated and burned the plastic pickup bed - I fixed that by removing and cleaning the spark arrestor and it has never glowed red again.  I would really like to put a guage in place of the digital idiot light since (from experience in automobiles) by the time the idiot light goes on you have already damaged the engine - Which brings the second question - would it be advisable to swap the front radiator sensor for a real sensor and then jumper the fans to always on condition at the connector so the computer contentedly thinks everything is working and it is doing its job ?
       


×
×
  • Create New...