Quantcast
Jump to content

  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Beetle1
      2012 hisun 700 efi front runner  turns over hard and the valves don't move and no compression  any ideas on what could be wrong with it ???? Thanks in advance 
    • By Mac250
      Just purchased a 2018 Hisun Sector 250. The gear shift is hard to engage. Tried depressing the brake pedal, no change. Tried with the engine running and turned off, no change. The gear shift cable, from the dash to the trans seems to be grinding. With my hand on the cable I can feel it grinding, vibrating, as the gear shift is moved up or down. Can this cable be removed and greased or does it just need to be replaced?
    • By Wild child 911
      I have a 2018 model Hisun 450 EFI UTV. I have done over 6000 trouble free kilometers. About 4 weeks ago i felt that utv was not performing like it should. Done a compression test and found to be low. Replaced rings as they were worn. I drive in a very dusty environment. The problem of low power is still there. I have checked cam timing, valve clearances, compression up to 9.5 bar, done leak down test and valves are seating, stripped and cleaned fuel pump, removed and cleaned throttle body, checked for leaks on throttle body manifold, replaced spark plug, tested stator coil, tested hv coil,  checked all electrical connections, checked injector. UTV starts easily and idles for 5 seconds and cuts out. When utv starts, it will rev up the first time and then start to miss as if it goes into a limp mode. If i lift my foot of the accelerator utv will idle for 2 seconds and then die. It starts immediately again. Would the air flow/ air pressure sensor or exhaust gas(lambda) sensor cause this. I cannot test them as dont know the correct values. Any suggestions will be highly appreciated.
    • By Robert Sawyer
      So I have a 2018 Massimo 500 and bought with 100 miles on it and only 400 now. It has worked and ran perfect. I noticed towards cooler weather it wasn’t idling and then just not running good at all. 
      things done - replaced the ignition coil replaced the plug checked cord for voltage. Drained gas cleaned tank went to a Rec fuel. Cleaned fuel filter screen at bottom of fuel filter. Cleaned main line and screen (had some residue) no air leaks I can find. Checked cleaned air filter. Cleaned and tested air intake control. Removed cleaned and tested the device moves o ring also fine. 
      I am not at a loss I can not get it back to where it was I have attached video of running etc 
      HELP 
      IMG_1823.MOV
    • By Maverick Barnett
      I just recently traded for one. Its 4wd..all lights gauges work..dump bed. Seats need recovered..and it wont start. I found burned wire going to the fuel cell. It will run for a few seconds on starter fluid. If I decide trade or sell..what's it worth as is?


×
×
  • Create New...