Quantcast
Jump to content

calebcobb1994

Massimo 700 EFI No Spark

Recommended Posts

There is no spark to plug and no power to fuel pump. I can run a direct ground to fuel pump to get power but still no spark at plug. Any ideas to what could be wrong? thanks!!

Share this post


Link to post
Share on other sites


Do you have a copy of the factory service manual? if not I can get it to you. I would also inspect the fuses next to the battery. Make sure there is no blown fuse. Also make sure the battery is at full charge.

Share this post


Link to post
Share on other sites

Check the fault codes, to see them do this:   When fault comes up, the odometer's clock will turn into a number find out the cause with this number; press clock button, then it will turn back to clock mode, and five second later the fault code will show again.

Share this post


Link to post
Share on other sites

it might have a code like this:

0562 = System Voltage Low

0563 = System Voltage High

0650 = MIL Circuit Malfunction 

Share this post


Link to post
Share on other sites


Send me private message with your email and I'll send you a link to the OEM manual.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Steve Waldner
      I have a Kioti  Mechron utv and want to add power steering. Can anyone till me if there is an electric assist motor from a car that would work putting between the steering wheel and steering box. One that doesn't need alot of electronics 
    • By Weathered
      We have been having all kinds of fuel issues with this ranger.  When you try to start it when it is cold outside, it does not want to start.  It will crank over fine but doesn't start but if you stop and come back 10 minutes later or so, it will start up.  But even then, it is idling real bad.  Usually will die a few times before you can get going, really have to feather the gas pedal to keep it alive.  Once it gets warmed up, it does start better but something still not right.  Even when it is warm outside, it will start up but just doesn't idle right.
      I bought a fuel pump kit, not the whole assembly, just the pump and replaced that and the same thing happens.  I am in the process of trying to check the fuel pressure on it but the fuel pressure gauge I got from our local auto parts store seems to be defective.  Had it hooked up and can't get the gauge to show any pressure at all yet it will still start up.   If it does have the correct pressure, what would be the next place to start looking at?  If it doesn't have correct pressure, is there something else on the assembly that would cause low pressure?  We checked the voltage on the connecter and one gets 12 volts for just a few seconds and the other one gets 4.9 volts.  The other 2 show nothing.  I am guessing the one with 4.9 volts is for the fuel gauge sender and the one that has 12 volts is the pump.   When you take the fuel line off on the engine side and turn the key on, how far should it throw fuel out?  
      We have taken it to 2 shops and neither one was able to do anything with it, one said there was nothing wrong.  Not sure if they really did any checking or what or they just don't know what to do with it.  
      Would the whole fuel pump assembly out of a ranger 570 work with the ranger 800?  Would I be able to swap them without any issues?  To buy a whole new assembly, it's around $400, don't really want to spend that much not knowing if it will fix it or not.  
    • By Muledaze
      Dipstick shows pale color, dont think its water, smells like fuel, oil changed one week ago, level is very high.
      First I thought it was water condensed into the oil...but someone pointed out the smell, and it doesn't look white-milky. And a half qt or so in one week?
      So is it possible to get fuel leaking into the oil?
       
       
    • By mixfixdave
      I had been wanting to install power steering on my T4 for years so I went to the salvage yard last weekend and bought a complete column (minus airbag) out of a 2009 Nissan Versa for $125 with the ECU.
      It was a fairly simple install. The long shaft that fits to the Joyner steering rack actually fit perfectly into the Nissan column. Had to weld up a U joint on the Nissan column to make it a straight shaft and fab up one simple bracket. Connect power and ground plus a switched 12v and now I can steer with one hand!

       
    • By Kannon09
      Hi, 
      Just purchased a 2015 Massimo 400 EFI. While I was cleaning the air filter sponge I noticed fuel was dripping out of the air box. Any ideas where this may be coming from? 
      Since it has electronic fuel injection I wouldn't think a carb float would be stuck or something like that. 
      Any advice is appreciated.  


×
×
  • Create New...