Quantcast
Jump to content

Recommended Posts



Good lookin' machine and some beautiful scenery!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By 2scoops
      Anyone have an outer cv joint ball cage? Mine is cracked up. Other than that it's a good axel.
      Please let me know
    • By kandlinaz
      Well, after a bad experience with repairs to our Trooper, Lloyd tore into the engine himself. We originally wanted to save time by hiring the engine rebuild out, but that bit us square in the butt. Remember the discussion about Silverbullet motorsports in Yuma??
      Stay tuned....we'll let you know what happens. 
      Has anyone rebuilt the engine in these troopers?
    • By fettman1176
      Hello there, I have 4 T2 troopers, 2 of them start and run like Champs, 2 of them have the issue. They will crank and crank but not start. Takes about 20 to 30 minutes to get them going, then they will run all day long and fire up at will every time. It's just the cold start they have a problem with. Since I have 2 that run good, I have swapped every part you can think of from the fuel system to ignition system with no success. I'm pretty stumped and am looking for any advice 
    • By Dwight
      Hi new to the Joyner trooper family just purchased a 2008 trooper, however the speedometer , coolant temp and voltmeter are not working I was hoping it was a continuity or ground issue but the copper is testing good, it appears the voltmeter is bad as my fluke works off the plug-in behind the gauge, tested the water temp sensor have 5 volts arriving, and approximately 3000 ohms on sensor cold no idea what I should get. As far as the speedometer have no idea how to test again copper seems to have good continuity. Any help would be greatly appreciated.  Thanks Dwight 
    • By 2scoops
      I am interested in any old trooper axle parts you may have lying around. Please let me know if your want to sell them. 
      Backstory:
      Hey everyone. Last trip out to moab I climbed a wall on poison spyder Mesa while 2 rzr xp1000's and three can am x3 xrc's watched me and didn't dare try. After doing it once I pulled around to show them it wasn't a fluke. One on the can am x3 xrc drivers just looked at me and said "that's steep". On the second try I spread the bell on the left rear axle. I made the climb but now the inner cage slips inside making a loud popping noise as twisting the boot. I mainly just need the inner bell but I am interested in anything you have. 


×
×
  • Create New...