Quantcast
Jump to content

johnney

2011 yardsport ys 400

Recommended Posts

i have a 2011 ys 400 when I start it cold it revs real high and when it warms up it won't  idle,    ive'e  been through the carb twice and cleaned out the gas tank , still no change

HELP............................................. JOHN IN MN.

Share this post


Link to post
Share on other sites


Does it have a manual choke? is it working properly? 

Share this post


Link to post
Share on other sites

the choke should move accordingly to how much you choke it. Full choke, the air butterfly should be closed, 1/2 choke, about 1/2 way open.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By CamJordan
      Does anyone know if I can get a rebuild kit for a PD36J or PD36J-C carburetor and if so please post a part number? Thanks
    • By SethZ28
      Hello everybody, Im new the forum actually it's my 1st post. I just recently purchased a used 08 trooper at the local bank. It has 535 miles and its camo. That had it as a repo, everything seems to be in really good shape. There's just 1 problem it won't run. They said it needed a ECU I purchased a ECU still nothing. All the lights work, 4 wheeldrive works, horn works, and everything else up front. The engine will crank but wont start no fuel or spark, fuel pump won't even run and the fan will not come on. Crossed over the relays to turn fans on fuel pump and get spark. Still nothing, I would really appreciate any good advise on which direction to go next.
      Thanks Seth
    • By Brian Lytle
      2019 650 comrade within the last two weeks I have had to jump start my odes something is staying on I have checked all lights etc I took off negative cable it sparked on me taking it off what the ?
    • By Tomoto
      Hey folks. I recently acquired a pre-owned Hisun 500, carburated. And surprise... it has issues.
      When cold, it typically starts without any issues, but once it warms up it tends to sputter and stall out. When accelerating, you can also feel it hesitating occasionally, and when you stop or put her into reverse, she will often stall.  The fuel is clean, I installed a new fuel filter, and the air filter is clean. Though the fuel pump appears to be working ok, it makes a strange knocking sound whenever power is put to it.  I've never heard anything like it, and I'm not sure if its shot or just a cheap Chinese pump thing. I have an aftermarket pump coming, and I've ordered a new ignition coil as well on the off chance that it is faulty. I am hoping replacing these two parts will solve the issue,  and if it does I will post the results here. 
      If not, anyone have any other ideas?  Also, I've noticed it is very difficult to find parts for this make... any suggestions on a good source for Hisun parts? I appreciate any comments or insights. 
    • By TIC
      hi. i got a 2017 warrior 700 . fuel injected, suddenly it wont idle, wont start unless i press peddle then it starts with clutch engaged, i can tell  the cicuit aint working for idle maybe fuse. ordered manual from sc autosports, taking its sweet time , dont know were anything is , is there a fuse block or something, anyone familier with the fuel injection on them things


×
×
  • Create New...