Quantcast
Jump to content

Utv51

2015 Hisun 500 S by S voltage rectifier plug issues

Recommended Posts

Posted (edited)

Hello hisun owners! I love my utv.

but as well other utv types mine needs some help from time to time.

the voltage regulator fried  a pin hole on the plug it goes into. There are 6 pins on voltage regular so I am trying to find the plug that it connects to. No luck online.  Called Coleman company and waiting for help to replace plug. 

Anyone have a clue where I can buy a new plug?  I use my utv for several projects and need this fixed fast! 

Thank you for any helpful replies.  

 

Edited by Utv51
Typos

Share this post


Link to post
Share on other sites


Welcome to the forum!

 I wasn't sure which series HiSun you had, but  you can find them on the left side of this  Parts page. you might can find it here. https://alpha-sports.com/hisun_parts.htm?q=hisun-parts

 One thing i would think about before putting a new plug on, is what caused it to burn it out. Could be just a cheap part, or just time won the battle, or another electrical issue.

a regular 6 pin would more than likely work, but  im not sure if the wires are supposed to go a certain way or not.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By OlEd
      Head gasket replacement, what’s a top quality head gasket to use? Should a person stud the head? Where would I find a place that sells both? Thank you for any info. 
    • By OlEd
      Hisun 500 having overheating problem after water pump install. Should  engine have a thermostat ? Has a thermostat housing but no stat, parts diagram showed it doesn’t. If it does where would I get one if Hisun doesn’t offer?
    • By Tomoto
      Hey folks. I recently acquired a pre-owned Hisun 500, carburated. And surprise... it has issues.
      When cold, it typically starts without any issues, but once it warms up it tends to sputter and stall out. When accelerating, you can also feel it hesitating occasionally, and when you stop or put her into reverse, she will often stall.  The fuel is clean, I installed a new fuel filter, and the air filter is clean. Though the fuel pump appears to be working ok, it makes a strange knocking sound whenever power is put to it.  I've never heard anything like it, and I'm not sure if its shot or just a cheap Chinese pump thing. I have an aftermarket pump coming, and I've ordered a new ignition coil as well on the off chance that it is faulty. I am hoping replacing these two parts will solve the issue,  and if it does I will post the results here. 
      If not, anyone have any other ideas?  Also, I've noticed it is very difficult to find parts for this make... any suggestions on a good source for Hisun parts? I appreciate any comments or insights. 
    • By bjones
      2007 610 mule will foul a pug after 1 hr of run time on clock.  Plug will be black with sut.  Buddy go a 610 and it does same thing. Have had dealer adjust valves twice and still does it.  When i bought mule valves were ticking and I ran it that way for some time and took it in and dealer adjusted valves and that is when problem started.  I rechecked valves and the were tight and I adjusted to .005 and still fouls plug.  I always use no ethenal gas and have gone to a hotter plug.  I have read that this is a common problem with mule.  Any help appreciated.
    • By strike250
      Hey there, new member here, just looking for information and tips. I just purchased a Hisun strike 250 for my young son. We have taken it to elsinore mx park here in so cal and he had a blast. I know I am going to get a lot of feedback regarding this, but I have to tell you, for the money, and his age, I can't complain. It always starts, is a blast to ride, and yes, I can fit in it at 6.1 and 195lbs. Have we had any issues? sure, but about the same about as any other vehicle, so I can't really complain. We couldnt find any aftermarket parts for it, so we engineered our own 2 inch lift kit for it, and it worked great. We have mounted additional lights on it as well. Some of the things we did notice are that the shift linkage seemed to be rubbing the exhaust pipe, and so I modified the shift linkage, and now that problem is gone. I also noticed that the factory plastic is very brittle, meaning it will crack if not handled properly. The quality of the OEM nuts and bolts are very poor, they seem to strip out very easy. So, we are replacing what ever bolt we remove, with a higher quality version. The battery is not easy to access, and in a pinch, that could be a problem, as tools are required to get to the battery. If you were to need a jump out in the boonies, you might be stuck. Also, the factory 4 point harness is hard to adjust, so we might have to replace them with aftermarket versions. Aside from that, he has not really had any problems with it. Granted it is not a larger 500 or 900cc UTV, so the load and demands on it are less. I do wish it had more power, but since he's only 9, I am good for now lol. It never quit on us, ran great in 106 degree heat, and handled the muddy track with ease. Another plus, it fits in the back of my truck bed with the tailgate up lol. Just my 2 cents.



×
×
  • Create New...