Quantcast
Jump to content

Bebop86

2014 volunteer just went dead

Recommended Posts

guys- machine ran fine - Pushed button to put in 4 wheel drive and the machine died- I have power at battery and to the fuses but everything is dead-- PLEASE let em know of any ideas- I really do not know what else to look for- thanks

Share this post


Link to post
Share on other sites


Come on guys someone must have an idea-= Checked again and I have no power coming to wiring harness ignition switch- anyone know where the safety switches are located= really not sure where to look anymore please help--

Share this post


Link to post
Share on other sites

Not a lot of information out there for sub branded machines.

All I can think of is Contact Cub Cadet 

Share this post


Link to post
Share on other sites

Sounds like a dead short in that swith, or somewhere in that circuit. Probably blew a main fuse. You said you've got power TO the fuses. What about after? Limbs, and rocks, and other road debris is often the culprit here. Check the switch with a continuity tester. Then look around underneath where the wires go into the front drive. Or the transaxle or whatever it has. 

It's possible that it's something else, but since it happened when you hit the button. That's where I'd start looking. If it's a push button activated 4wd. There's a relay that'll drive the actuator. Both those are prime suspects.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By fettman1176
      Hello fellow Joyner dudes, i am looking for any ideas or pics on some doors my Trooper fleet. Any advice would be appreciated.

    • By Akovia
      We have a Hisun Sector EV that is hard for the grandkids to steer. Has anyone heard of adding power steering to this model? Thanks!
    • By Thomas T.
      I have a 2014 massimo 500. Where is the best place to order an power steering kit for it. Real hard to steer. Thanks in advance
    • By Akovia
      Our new Sector E1 electric has 45 miles on the odo.  It frequently goes into shutdown mode after a few minutes of putzing around the farm. Instrument panel gives a flashing message “45C”. I presume that this means the batteries are overheated. The temperature indicator is maxxed. No stunt driving involved, just the grandkids bumping along in low range across the pasture. Of course, the owners manual does not reference this condition. We park it for a while and it returns to normal; at least until the next overheat. Has anyone else been bothered by this?


×
×
  • Create New...