Quantcast
Jump to content

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Tomoto
      Hey folks. I recently acquired a pre-owned Hisun 500, carburated. And surprise... it has issues.
      When cold, it typically starts without any issues, but once it warms up it tends to sputter and stall out. When accelerating, you can also feel it hesitating occasionally, and when you stop or put her into reverse, she will often stall.  The fuel is clean, I installed a new fuel filter, and the air filter is clean. Though the fuel pump appears to be working ok, it makes a strange knocking sound whenever power is put to it.  I've never heard anything like it, and I'm not sure if its shot or just a cheap Chinese pump thing. I have an aftermarket pump coming, and I've ordered a new ignition coil as well on the off chance that it is faulty. I am hoping replacing these two parts will solve the issue,  and if it does I will post the results here. 
      If not, anyone have any other ideas?  Also, I've noticed it is very difficult to find parts for this make... any suggestions on a good source for Hisun parts? I appreciate any comments or insights. 
    • By Franck Euksuzian
      Looking to either buy a 2016 ranger or a Yamaha Viking. I was told that the Viking is less powerful. What are the pros and cons of each and which one would you go with. Thanks
    • By Nolan55555
      Not priming fuel when you turn key on but pumps fuel when you crank it over what could it be? 2016 Yamaha wolverine 
    • By Jimmy Bellagio
      I have a 2009 Trooper 2 that sat in garage in Vegas for 2 years and fuel wen bad.  I replaced the fuel filter, fuel pump and drained and put new fuel with stabil.  So here is where it gets good I am getting fuel to the pump, pump is making noise like it’s working but no fuel will come out.  Anyone else have this problem?  The only thing I can think of is that I had to put the old outlet on the new pump, I cleaned and blew it out best I could. I can’t use the one from the new pump due to it being threaded.   Any good suggestions?  I checked fuse and relay, I even hot wired the pump.







    • By Matthew Zeller
      My grandpa has a Yamaha wolverine side by side. It has a solid rear axle.  The problem is it tears up the yard when he turns. Question is has anyone or can he make it into a differential by anyway gear box swap or change some gears. Thanks if you can help!
×
×
  • Create New...