Quantcast
Jump to content

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By ArrowLobber
      I'm new to this forum. I recently picked up a Hisun "Coleman" Trail Tamer 800 atv that was ran way too hard. I know this is a SXS forum but I'm trying to learn as much as I can about Hisuns and there is very little out there about the ATV's. I have done a complete engine rebuild, replaced the crank, con rods, pistons, rings, head gaskets, base gaskets. cam chains, U joints, front a-arms, replaced all rear pads, repacked trailing arm bearings. Replaced the rear diff with a used one, have a rebuild kit in the cabinet. Put it all together, no spark. Somehow got spark and fuel and it started and purred like a kitten. Pulled the exhaust off to replace the gaskets, replaced the battery and starting relay switch. Turns over but no spark and no fuel again. Have taken apart almost every connection and added grease, still nothing. So jumped on this forum to try and apply any learnings from here to my project. I'm about to pull all of my hair out and Ima already going bald. Any help and input is GREATLY appreciated.
       
      2014 Coleman "Hisun" Trail Tamer 800
    • By SethZ28
      Hello everybody, Im new the forum actually it's my 1st post. I just recently purchased a used 08 trooper at the local bank. It has 535 miles and its camo. That had it as a repo, everything seems to be in really good shape. There's just 1 problem it won't run. They said it needed a ECU I purchased a ECU still nothing. All the lights work, 4 wheeldrive works, horn works, and everything else up front. The engine will crank but wont start no fuel or spark, fuel pump won't even run and the fan will not come on. Crossed over the relays to turn fans on fuel pump and get spark. Still nothing, I would really appreciate any good advise on which direction to go next.
      Thanks Seth
    • By Brian Lytle
      2019 650 comrade within the last two weeks I have had to jump start my odes something is staying on I have checked all lights etc I took off negative cable it sparked on me taking it off what the ?
    • By fettman1176
      Hello fellow Joyner dudes, i am looking for any ideas or pics on some doors my Trooper fleet. Any advice would be appreciated.

    • By TIC
      hi. i got a 2017 warrior 700 . fuel injected, suddenly it wont idle, wont start unless i press peddle then it starts with clutch engaged, i can tell  the cicuit aint working for idle maybe fuse. ordered manual from sc autosports, taking its sweet time , dont know were anything is , is there a fuse block or something, anyone familier with the fuel injection on them things


×
×
  • Create New...