Quantcast
Jump to content

Moosehunter

2019 Hisun sector 750 Parking brake mod

Recommended Posts

Anyone doing a mod on the parking brake?  It’s very awkward to press if you have long legs . 2019 Hisun sector 750

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Wyatt Carneal
      Hey guys.
      I have a 2009 hisun 700 I bought bout 2 weeks ago and it was running fine but was hard to start but once warm it fire rite up  i took the  air filter off and it was nasty so I gave it a good cleaning and it hasn't started since. Its cranking over really slow I replaced the starter. I also replaced the batery. It acts like its not releasing decompression  I found a service manual on line and downloaded it and it said the intake valves setting .010-.015 mm  and exhaust is .015-.020 and they all was set on .008 intake and exhaust. And the timing is set I set the intake to .012 and exhaust to .016 and it still cracks over really slow I'm lost and don't know wat else it could be. Anyone have any ideas.  And help would be great thanks .
    • By ArrowLobber
      I'm new to this forum. I recently picked up a Hisun "Coleman" Trail Tamer 800 atv that was ran way too hard. I know this is a SXS forum but I'm trying to learn as much as I can about Hisuns and there is very little out there about the ATV's. I have done a complete engine rebuild, replaced the crank, con rods, pistons, rings, head gaskets, base gaskets. cam chains, U joints, front a-arms, replaced all rear pads, repacked trailing arm bearings. Replaced the rear diff with a used one, have a rebuild kit in the cabinet. Put it all together, no spark. Somehow got spark and fuel and it started and purred like a kitten. Pulled the exhaust off to replace the gaskets, replaced the battery and starting relay switch. Turns over but no spark and no fuel again. Have taken apart almost every connection and added grease, still nothing. So jumped on this forum to try and apply any learnings from here to my project. I'm about to pull all of my hair out and Ima already going bald. Any help and input is GREATLY appreciated.
       
      2014 Coleman "Hisun" Trail Tamer 800
    • By justingrider
      Good morning everyone, appreciate any help on this.  I picked up a 2013 Hisun 800 for a project.  Previous owner had fried a lot of the electrical with a bunch of aftermarket audio equipment, so I have been replacing all of the wiring to give it a fresh start.  I'm 95% there with a couple of plugs I can't figure out where they need to be routed and the reason for me reaching out for help here.
      1.  A female 2-port white plug that comes off the end of the main harness, close to the side where the terminal hook ups tap into the battery.  It has a Blue/black-stripe wire and a White/blue-stripe wire. (Pictures: https://ibb.co/m9PRDqX and
      https://ibb.co/9pHZsFj). I'm assuming it is another single offset fuse or module like the other pieces around it but can't find anything on what it might be or that wire color combination in the manual/wiring diagrams...anyone know what this guy goes to?
      2.  On the crank position sensor (torque sensor), the wires that I have coming off of that are a green wire and blue/light-gray-stripe wire (https://ibb.co/FmJLJfs)...any idea on where this guy is suppose to plug in to?
      Again, thanks for any help you can provide!
      -Justin
       



    • By Chris B
      Hi,
      Don't know much about anything utv but I figured out my fuel pump wiring harness needed to be replaced. Installation looks pretty straightforward, plug into fuel pump and plug in the two pigtails. Question is: one of the Pigtails on the old harness I am replacing had a splice in the black wire and attached to a bolt on the engine. Is this necessary?  Is the black wire, I'm assuming it's the ground, grounded at the other end of the pigtail?
    • By Travis
      The cables are sort of seized up on the emergency brake, they still work but i have to wiggle and pull on em to get them to release, i pulled the drum off but cant see a way to remove the cable. It is kind of dirty inside the drum where it was leaking so i need to run to the parts store and buy some parts cleaner so i can see everything better.
       The shop manual i have  does not cover parking brake cable removal, well.... it does kind of. it says "Remove parking brake cable at both ends" 🙄
       We'll see
       EDIT: ARRR! Looks like my rear axle seal is leaking, there is a small puddle on a machined step below the seal and it smells like Trans oil. felt around the wheel cylinder and it isn't coming from their.....  I guess my weekend is planned for me LOL
  • Similar Tagged Content

    • By Tom Rosecke
      So i have a 2018 Hisun Sector 750 Crew and while driving the noise level is outrageous.  I want to find a way to decrease the decibel level, so does anyone have any ideas!!! i was thinking about installing foam on the roof enclosure and possibly putting something around the engine bay area.  I have not found any companies that makes a suppressor for the muffler...Any help would be appreciated.  thank you
    • By JeremyH
      I recently replaced my rear driveshaft on my 08 Commando 650.  Unfortunately, the parking brake rotor was welded to the old one, and the new one did not have one.  The folks at Joyner recommended just moving the caliper to the rear wheel as there is a second bracket I could mount it to.  However, the brake line is too short to reach that bracket, anyone done this reposition before?  Are there standard size brake lines and fittings that I can buy to move it?  Right now I have it bolted back up to the factory bracket but it sucks to not have a parking brake.


×
×
  • Create New...