Quantcast
Jump to content

Recommended Posts

I finally decided to take the carburetor off the mule and clean it,

Pull it off, piece of cake....

Take off the bowl, here is what it looked like.IMG_20191129_110850.thumb.jpg.c711cce70885b7eff4bf6fd113fbf62c.jpg

 

Then I proceed to pull out the float pin, sigh 

IMG_20191129_112003.thumb.jpg.f479aa6aee72d93cdd7fd93b74e83eaa.jpg

As you can see, part of the hinge casting broke off.

I contemplated JB welding it, but decided not too.Mikuni and Kawasaki are $170-$200 too proud of this carb.

I stooped low and bought a  $60 off of amazon.

Is rather go oem but couldn't in this case.

 

Oh well, nearly 20 years on 1 carb. not bad i guess. never took apart and cleaned, just b12 chemtool in the tank every so often.

Share this post


Link to post
Share on other sites


The 550?  Dang I saw one on Amazon for $15. If anything just use the housing and swap old parts in.  

Share this post


Link to post
Share on other sites

Yep, for the 550, a OEM mikuni is $170+

$60 seemed to be reasonable. I saw some for $30, or less but I really question the quality at that point.

Interesting thing I noticed, I'm used to Briggs carbs made by Nikki or Walbro.

This Mikuni uses a metal needle with a rubber tip instead of a metal needle and rubber seat.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By bjones
      Strange issue and it has happened twice.  Changed oil twice and after a while when oil is checked it is always to full on dip stick.  Looks like at least 1/2 qtr.  I have looked at manual and put in amount called for, 1.16 qt without filter.  What would cause level to appear to full.  Thanks
    • By Pamm r
      Mule still not charging after replacing a new regulator.  Need to figure out how to test the alternator at the plug on top of the motor.  Any easy way to check it?
    • By Acarguy
      I cant seem to get my mule into posi traction. The lever moves but i don't think im engaging it the right way? What is the procedure for getting it in posi traction?
    • By Shad
      Hey y'all, just finished replacing my rear right axle on my 99 mule 550. The old one teeth rounded out where the brake drum grabs it.  But now i can't get the drum to seat on the new axle far enough,  yes i put axles side by side,  identical,  i can reverse the drum and it slides right on the axle so i know it goes on fine.  It's a really bad design anyways with such a tiny line of teeth to rely on to drive the wheel.  Does anyone know if the new brake drums have deeper teeth to grab more of the axle?? Or any ideas why im having a hard time with this damn thing? 
    • By dalem
      Earlier this year my battery was weak and I had to boost my mule to start it then I decided to remove the battery to check the fluid level which was very low, I set the levels and recharged the battery a few months later it did the same thing, so I had to boost it again then checked the voltage running was getting around 16 vdc ( which is too high) and fluid level was very low again and wouldn't hold a charge. Note: The battery was maybe 1-1/2 years old. Then I replaced the battery and checked the voltage running nothing changed I was only reading battery voltage it wouldn't increase with increased engine speed. I changed the voltage regulator with an aftermarket  one, same thing not charging. I checked the alternator per the service manual which states .3 ohms or less it checks at .2 ohms and not shorted to ground. With the engine running I disconnected the alternator and it had around 22 vac idling and around 60 vac revving the engine, so I figured the regulator was bad so I replaced it with another new one (aftermarket) from a different company, again not charging only reading  battery voltage. I did put the original voltage regulator on nothing changed still not charging. Using the manual wiring diagram did continuity checks going to the voltage regulator everything checks out OK. Now what am I missing?


×
×
  • Create New...