Quantcast
Jump to content

farmerjohnky

2015 Polaris Ranger 570 Midsize Kicks Out Of Gear / Free Wheels

Recommended Posts

Hey. I recently got a used Polaris Ranger 570, and I’ve noticed if I let off the gas going down a hill, after about 5-10 seconds, it kicks out of gear or free wheels. Is this normal? It’s kind of annoying imo, since you have to hold your brake so much more. Also, is it bad to leave it in 2wd Diff Lock? I have turf mode, but like to keep it in diff lock because I climb some pretty steep hills frequently. Is it bad to engage/disengage diff lock/4wd while moving or in a pull? Thanks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By strike250
      I have the factory service manual available for the Buck 400. Just send me a message with your email and I'll get it to you. Although there is no charge for this, it would be great if  you would visit my website where you could donate any amount to help do things like this with others who need it. Again, there is no charge for this manual, and no obligation to donate. But if you did, I would thank you for sure. Have fun on the trails. www.warriorsoffroad.com
       
      Matt

    • By Anthony Butler
      Soo for my second problem lol, 2009 trooper 1100 5 speed , will not engage 5th gear , all others work fine but seems like 5th doesn't engage completely and wont grab the gear. Any idea on where to start looking for issues, or what to look for in regards to linkage. 
    • By johnpeter
      2018 Polaris RZR Xp Turbo Fox Edition  On Ebay
      https://www.ebay.com/itm/2018-Rzr-Xp-Turbo-Fox-Edition/133521215367?

    • By Gorj
      Do not know if any of you Hisun E1 owners have  had issues with the parking brake pedal  not returning completely, thus preventing you from moving forward or reverse.   I had this issue and even sometimes when going over rough road the parking brake pedal would move down far enough to shut off power.  Local  dealer said no one had complained about that issue and they had no fix.  So decided to correct it myself. I installed a return spring on the parking brake arm and it stopped the problem!

    • By johnpeter
      2015 Polaris RZR XP 1000 eps On Ebay
      https://www.ebay.com/itm/2015-Polaris-RZR-XP-1000-eps/283999525191?

  • Similar Tagged Content

    • By jwienrich
      HI new to the forum so this is my first post and problem. So I have a 2005 Ranger 500 6x6 with a carb and do not have any power to the fuel pump. Research has suggested that it could be the pdm but after looking extensively through my machine I cannot find a pdm. I can only find 3 flat black thin boxes under the hood on the passenger side. Are there some ranger 500's without pdm's? I bought this machine new and it has never been messed with. This machine has been in storage for several years and has only 12 hours on it.
      Thanks, Jeff
      My Bad just looked at my title and its a 2004 not a 2005 so no PDM or ECM. Wiring is quite different so I need to take another look.
    • By Hoytlifer
      I have a  2019  Ranger 900 XP EPS that I would like to change the factory headlights to LEDs.  Has anyone done this, if so what style of bulb was used.?
    • By Lester Richards
      Took it out the other day, it died and engine temp light came on and I heard the gurgling in the radiator. I let it cool for few, got it home in limp mode.  fan kicks on but im not sure 40 seconds is long enough and/or if it kicking on all the times when it needs to be. fan relay works id assume or fan would never operate. Took temp sensor wire off and fan does NOT auto kick on like I was told. No debris in front of radiator, its full , correct level on overflow tank. unit has 1,600 miles, iv had if for 6 months and all the sudden I get this issue.
    • By Brett
      Fuel injected 700 starts great and idles great but touch the gas and it dies
    • By Mac
      I have a 2005 Polaris Ranger 4 x 4, I have all forward gears but I have no reverse.  The gear selector is working but after this reverse in not engaging anyone have the same issue and if so how do I go about fixing it?


×
×
  • Create New...