Quantcast
Jump to content

Robert Sawyer

2018 Massimo 500

Recommended Posts

Hello!

I purchased a 500 with 100 miles owner didn't use like wanted.  I have been using (live in Michigan) just started getting cold and now i am having a stalling issue all the time.  The unit start runs great but when come to a stop it normally stalls, and when give it power it can bog at times.  I know there are the obvious plugs, fuel filter etc but all seem ok, figured there might be a trick tip to this before i dive in.

2. When i take the center cover off there is a pipe that is not covered?  what is that for ?  should it have been covered?

Not sure it weather is connected i let it warm up but usually have to hold pedal down.  Ran perfect since i bought it and now acting up

 

Thank you in advance

Share this post


Link to post
Share on other sites


If the carburetor is adjustable, it's probably running a lean air fuel mixture.

Smaller engines in cold weather like rich mixtures (more fuel than air)

When you come to a stop, choke it just a little bit and see if it runs better.

Share this post


Link to post
Share on other sites

Probably  mouse nest in air filter. Run some seafoam in the gas tank and change the spark plug. Efi engine should run fine in the cold

Share this post


Link to post
Share on other sites

May just be a bad batch of gas since you last fueled up . Try some gas line antifreeze to eliminate the moisture. It’s a cheap fix and it won’t harm anything

  • Like 1

Share this post


Link to post
Share on other sites

So I changed plug, cleaned air filter , went to recreational gas I am directed to the air idle control as coming up as error code however I can not locate the part on engine. 

 

Need location ion of air idle control 

Share this post


Link to post
Share on other sites


https://www.ebay.com/itm/IAC-Idle-Air-Control-Valve-For-HiSUN-400-500-700-ATV-UTV-Bennche-Menards-Massimo-/274012488967?redirect=mobile

Here is the part itself.

It should be located around the intake into The engine. I'll do some more looking.

10 hours ago, Robert Sawyer said:

So I changed plug, cleaned air filter , went to recreational gas I am directed to the air idle control as coming up as error code however I can not locate the part on engine. 

 

Need location ion of air idle control 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By johnpeter
      2017 polaris rzr xp 4 1000 eps - 608 miles On Ebay
      https://www.ebay.com/itm/2017-polaris-rzr-xp-4-1000-eps-608-miles/333471922828?

    • By Swimmer1
      Fuel pump does not run when switch is turned on. I checked fuel pump and it is good.
    • By Kmrider
      Tried to buy a 2020 Kawasaki Mule Pro FXT and was told their was a stop sale on them, but the dealer had no info on what the problem was or how long until a solution is found to whatever the issue is.   Anyone know anything about this?
    • By Robert Sawyer
      So I have a 2018 Massimo 500 and bought with 100 miles on it and only 400 now. It has worked and ran perfect. I noticed towards cooler weather it wasn’t idling and then just not running good at all. 
      things done - replaced the ignition coil replaced the plug checked cord for voltage. Drained gas cleaned tank went to a Rec fuel. Cleaned fuel filter screen at bottom of fuel filter. Cleaned main line and screen (had some residue) no air leaks I can find. Checked cleaned air filter. Cleaned and tested air intake control. Removed cleaned and tested the device moves o ring also fine. 
      I am not at a loss I can not get it back to where it was I have attached video of running etc 
      HELP 
      IMG_1823.MOV


×
×
  • Create New...