Quantcast
Jump to content

dant849

Brand new 2018 Tboss 500 Cooling Fan Not Working

Recommended Posts

Hello, just took delivery of this unit today and temp gauge shows it's running hot . Full of coolant. Fan isn't coming on although I can jump it. Relay and fuse are good. What else can it be? Thanks in advance!

Share this post


Link to post
Share on other sites


I'd take it back to where you bought it/who sold it to you,  it should be their responsibility that everything is in working order.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By johnpeter
      2009 POLARIS RZR 800s w/FULL POLY CAB On Ebay
      https://www.ebay.com/itm/2009-POLARIS-RZR-800s-w-FULL-POLY-CAB-HEATER?

    • By Robert Sawyer
      So I have a 2018 Massimo 500 and bought with 100 miles on it and only 400 now. It has worked and ran perfect. I noticed towards cooler weather it wasn’t idling and then just not running good at all. 
      things done - replaced the ignition coil replaced the plug checked cord for voltage. Drained gas cleaned tank went to a Rec fuel. Cleaned fuel filter screen at bottom of fuel filter. Cleaned main line and screen (had some residue) no air leaks I can find. Checked cleaned air filter. Cleaned and tested air intake control. Removed cleaned and tested the device moves o ring also fine. 
      I am not at a loss I can not get it back to where it was I have attached video of running etc 
      HELP 
      IMG_1823.MOV
    • By Free2bdaring
      I have bought a 2018 Joyner R2. So far I love it. I was not impressed with the dealer I bought from and am wanting to buy some accessories. Can anyone recommend a good dealer or supplier?
    • By Glock_King
      AC blows cold for while ... meter shows 2amps then all of a sudden spikes and blows fuse ... and not necessarily when AC clutch engages .... 2012 model with only 126 hours ....  any ideas ?
    • By dennardo
      I recently bought a used Kubota RTV900 with a plow attachment to take care of a long, steep driveway this winter. I think it’s a 2006 and it has about 460 hours on it. The previous owner told me when I bought it that it needed an oil change but I know nothing else about how well it was maintained over the years. While going through the items in the maintenance schedule I discovered a problem with the coolant system. The coolant reserve tank was completely empty so I filled it and soon after noticed a spot of antifreeze on my garage floor. I had never noticed a leak before. I took the protective panel under the radiator off the bottom of the RTV and could see that the radiator itself, the drain valve, and all hoses and connections were dry and tight as far as the hose going into the engine block. I then took off the next protective panel that is right under the forward part of the engine. The engine-facing side of this plate was covered with a mess of oily debris that had to be scraped off and the engine itself was pretty dirty also. I cleaned things up with some paper towels and ran the engine to see if I could spot any leaks. After running the engine for only a few minutes, I saw a drop of coolant on the side of the crankcase right behind the starter motor. I wiped it dry, started the engine again, and the drop re-appeared after a few minutes. I was expecting to find that maybe the water pump was leaking, but I don’t see how that would cause the coolant to appear so far back on the side of the engine block. I can’t see anything else that might spray coolant onto this area. If the cylinder block actually has a hole in it I would expect I would see a lot more problems than just a slow leak of coolant.  I am fairly handy but as I’m sure you can tell I’m new to engine work so I thought I’d see if anyone could help me diagnose this problem. Thanks.




×
×
  • Create New...