Quantcast
Jump to content

Maverick Barnett

2010 Hisun 500..estimate of its value?

Recommended Posts

I just recently traded for one. Its 4wd..all lights gauges work..dump bed. Seats need recovered..and it wont start. I found burned wire going to the fuel cell. It will run for a few seconds on starter fluid. If I decide trade or sell..what's it worth as is?

Share this post


Link to post
Share on other sites


From what I read brand new they were $6400

As is?

Well ,sight unseen,  I would not pay over $2000 for one that I would have to work on once I bought it. If you fixed it, you can get more for it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By Felixbot
      I’m working on a 98 mule kaf620. The fuel pump failed. It was making a loud clicking noise and would not accelerate. I replaced it with the cheapest pump I could find on amazon. It failed after a few days. We bought another pump from fuel pump factory and installed it. It began leaking from the seam in the body after about 10 minutes. I contacted them and they sent another new pump. After installing it, same thing; leaking at the seam of the pump. I’m not sure how to move forward. Does this pump have some sort of internal bypass? Being an electric pump, it cannot run all of the time. What am I missing? 
      Any help would really be appreciated, as a grandmother uses this to feed her cattle and is using a red wagon until it is fixed.
    • By Swimmer1
      Fuel pump does not run when switch is turned on. I checked fuel pump and it is good.
    • By Brad
      Hi I bought a project 2008 odes 400 utv. Does anyone know how the fuel hoses hook up and where does the fuel return hose connect to?
    • By Carolynski
      I have a Q-Link (Rhino clone) and the fuel injector won't open up and spray. The fuel pump is brand-new and kicks on and primes to the injector but nothing comes out.
      I've cleaned and dielectric greased the electrical plug and the ECU plugs but no change. not sure where to go from here. Any help?





×
×
  • Create New...