Quantcast
Jump to content

Robert Sawyer

Idle - stalling - running issues

Recommended Posts

So I have a 2018 Massimo 500 and bought with 100 miles on it and only 400 now. It has worked and ran perfect. I noticed towards cooler weather it wasn’t idling and then just not running good at all. 
things done - replaced the ignition coil replaced the plug checked cord for voltage. Drained gas cleaned tank went to a Rec fuel. Cleaned fuel filter screen at bottom of fuel filter. Cleaned main line and screen (had some residue) no air leaks I can find. Checked cleaned air filter. Cleaned and tested air intake control. Removed cleaned and tested the device moves o ring also fine. 
I am not at a loss I can not get it back to where it was I have attached video of running etc 

HELP 

Share this post


Link to post
Share on other sites


You've said that the cooler weather seems to be a factor. Is there a heated area where you could test that idea? Or put a tarp over the motor, with a heater underneath, in the garage? It really sounds fuel related. But air and fuel work together. So maybe it's an air sensor or some thing. Sounds like you've had a similar train of thought. Don't know where you are. But in places where there's a lot of ethanol in the fuel. It can be a problem for small gas engines. Creating a problem that's difficult to pin down. Not unlike yours. Have you checked the injectors? I really have no idea, just throwing out suggestions till someone who might know comes along.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Lester
      I just got this today and the tires are 26 on 12's. was wondering what id the larges tire I can put with out any lifting? if you have pics that would be nice. thanks
    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By johnpeter
      2017 polaris rzr xp 4 1000 eps - 608 miles On Ebay
      https://www.ebay.com/itm/2017-polaris-rzr-xp-4-1000-eps-608-miles/333471922828?

    • By Swimmer1
      Fuel pump does not run when switch is turned on. I checked fuel pump and it is good.
    • By Mac250
      Just purchased a 2018 Hisun Sector 250. The gear shift is hard to engage. Tried depressing the brake pedal, no change. Tried with the engine running and turned off, no change. The gear shift cable, from the dash to the trans seems to be grinding. With my hand on the cable I can feel it grinding, vibrating, as the gear shift is moved up or down. Can this cable be removed and greased or does it just need to be replaced?


×
×
  • Create New...