Quantcast
Jump to content

Beetle1

2012 hisun front runner 700 efi

Recommended Posts

2012 hisun 700 efi front runner  turns over hard and the valves don't move and no compression  any ideas on what could be wrong with it ???? Thanks in advance 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By rjfrider
      Mule Pro MX question:  Is there a trick to removing the center floor panel or "tunnel" other than removing the 8 plastic rivets?  I removed the rivets but the panel won't pop up easily, and I don't want to force it with a crow bar so as not to break some tabs or other hidden parts.  Accessory mount instruction attached.  Thanks for your help.  rider
      Mule Pro MX floor tunnel.pdf
    • By Mac250
      Just purchased a 2018 Hisun Sector 250. The gear shift is hard to engage. Tried depressing the brake pedal, no change. Tried with the engine running and turned off, no change. The gear shift cable, from the dash to the trans seems to be grinding. With my hand on the cable I can feel it grinding, vibrating, as the gear shift is moved up or down. Can this cable be removed and greased or does it just need to be replaced?
    • By Wild child 911
      I have a 2018 model Hisun 450 EFI UTV. I have done over 6000 trouble free kilometers. About 4 weeks ago i felt that utv was not performing like it should. Done a compression test and found to be low. Replaced rings as they were worn. I drive in a very dusty environment. The problem of low power is still there. I have checked cam timing, valve clearances, compression up to 9.5 bar, done leak down test and valves are seating, stripped and cleaned fuel pump, removed and cleaned throttle body, checked for leaks on throttle body manifold, replaced spark plug, tested stator coil, tested hv coil,  checked all electrical connections, checked injector. UTV starts easily and idles for 5 seconds and cuts out. When utv starts, it will rev up the first time and then start to miss as if it goes into a limp mode. If i lift my foot of the accelerator utv will idle for 2 seconds and then die. It starts immediately again. Would the air flow/ air pressure sensor or exhaust gas(lambda) sensor cause this. I cannot test them as dont know the correct values. Any suggestions will be highly appreciated.
    • By Maverick Barnett
      I just recently traded for one. Its 4wd..all lights gauges work..dump bed. Seats need recovered..and it wont start. I found burned wire going to the fuel cell. It will run for a few seconds on starter fluid. If I decide trade or sell..what's it worth as is?
  • Similar Tagged Content

    • By Chris B
      Hi,
      Don't know much about anything utv but I figured out my fuel pump wiring harness needed to be replaced. Installation looks pretty straightforward, plug into fuel pump and plug in the two pigtails. Question is: one of the Pigtails on the old harness I am replacing had a splice in the black wire and attached to a bolt on the engine. Is this necessary?  Is the black wire, I'm assuming it's the ground, grounded at the other end of the pigtail?
    • By Mlake
      Hi Everyone, This is my first post.  I believe I have my starting issues narrowed down to decompression springs (good grounds, one way bearing, etc.) so I order them and now I have no idea how to install.  I am handy enough, but looking for a video or other instructions on how to replace them.  If this has been covered and I just can't find it, appreciate some input on where to go.  If not, would appreciate some instruction!  Haven't done this one before.  Thanks.


×
×
  • Create New...