Quantcast
Jump to content

physics911

Massimo T-Boss 410 noise in 4wd low

Recommended Posts

I have a new, 2 week old, T-Boss 410 and with the differential locked, and also in reverse with or without diff locked, I am getting a metal-on-metal sound.  It still pulls fine in 4wd low, but definitely some substantial metal noise. I haven't actually checked the diff fluid, but there are definitely no leaks.  

Thoughts?

Thank you

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BigTver
      I have a problem in this video. Who here had the same? and how did you decide? I speak Russian, but I think your eyes understand 😉
    • By Mac
      I have a 2005 Polaris Ranger 4 x 4, I have all forward gears but I have no reverse.  The gear selector is working but after this reverse in not engaging anyone have the same issue and if so how do I go about fixing it?
    • By dant849
      Hello, just took delivery of this unit today and temp gauge shows it's running hot . Full of coolant. Fan isn't coming on although I can jump it. Relay and fuse are good. What else can it be? Thanks in advance!
    • By Jeremiah Hammond
      So to shorten it up, my rear diff on the strike 1000 exploded. And not from improper use, just a junk cast case probably full of air pockets. 
      Im trying to figure out another brand rear diff I could transplant in. There are plenty of wrecked rzr 800 all over the classifieds. I wonder how much fab would be required to do the transplant?
      anyone have a rzr and a Hisun they couple compare side by side?
    • By Kevin Slack
      I bought the sector hisun 550 for feeding deer, haven't had it a year yet and yesterday driving it I heard a bad noise. Took it back where I bought it and they said it sounds like the rear differential went out of it. Has anyone had any problem like this with there new hisun. I do have about 160 hours on it and 2600 miles. All easy driving miles.


×
×
  • Create New...