Quantcast
Jump to content

GarySeven

Hopefully I've Come to the Right Place...

Recommended Posts

I bought a Titan Explorer back in 2012 and have had nothing but electrical problems with it ever since. It mostly sits in the garage and I thin I have 160 hours on it since I got it. The place I bought it from is gone and although I suspect it is a Chinese or Japanese I cannot find any service manuals on it.

I'll post up some pics in the general forum in the hopes that someone can point me in the right direction. What I would like to do is to pull ALL of the wiring out and start over with bare bones... nothing but essential operations.

This looks like a good group so hopefully I can help as well as be helped.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jwienrich
      HI new to the forum so this is my first post and problem. So I have a 2005 Ranger 500 6x6 with a carb and do not have any power to the fuel pump. Research has suggested that it could be the pdm but after looking extensively through my machine I cannot find a pdm. I can only find 3 flat black thin boxes under the hood on the passenger side. Are there some ranger 500's without pdm's? I bought this machine new and it has never been messed with. This machine has been in storage for several years and has only 12 hours on it.
      Thanks, Jeff
    • By OldGoatLover
      I bought this thing last September.  The farm store was extremely nice. 
      But, forget asking for any advice like in the old days.  They only SELL them and tell you to call the Dallas tech person.  
      During the week days - I don't have time.  
      Oil change:  If there is someone who can tell me why the owner's manual (and the internet) says it holds 2 and 1/2 quarts of oil but, my mechanic could only get 1 and 1/2 quarts in it and there is NO oil filter.  
      Please help.  
       
    • By GDS
      I have just purchased a 07 3010 Mule. It has high hours at 1900 but has been well taken care of. It seems to run well but just a bit weak. Every now and then I hear a clinging sound that may be a ignition spark to ground but I can't seem to find it. It will not do it when I'm looking. Also the back plug is showing its rich. It is black in no time where the front is a lite brown. 
      I did find it had the wrong plugs so I changed them, but no help. 
      As I have just got this I was wondering what do I need to look at as far as simple mods or weak points. 
      Thanks for your help
    • By Robynne Catheron
      New-to-me 2012 CC Volunteer throttle cable broke during the wicked cold snap we had a few weeks ago (upstate NY). It was already a bit sticky, but at least it was usable. 
      Is it possible to replace it myself, or must I pay to have it hauled 50 miles to the nearest shop?  I can access both ends, but the majority of it is pretty buried from the top and underneath. 
      Any advice would be appreciated. 
    • By Robynne Catheron
      Just wanted to say hi. I'm very thankful for this forum, because I recently purchased a 2012 Cub Cadet Volunteer.  I need to be able to maintain it myself instead of having a shop come and get it. The closest shop is about 50 miles away. I appreciate any and all help and advice! 
      I hope I don't wear out my welcome here. 


×
×
  • Create New...