Quantcast
Jump to content

farmcrew

Looking for Commando 650 steering rack boots

Recommended Posts

I recently got a 2007 Commando 650 C4 and I'm in the process of going through it from stem to stern. The AZ sun has really taken it's toll on all the plastic and rubber. One CV boot is torn and the others are probably not far behind. Most of the rubber on the control cable ends are on bad shape and the steering rack boots are almost completely disintegrated. Anyone have a source for the steering rack boots?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By rpyne
      I have been going through the troubleshooting in the manual (pages 17-38 and 17-39), but I can't find anything that looks like the picture in the manual. If I run power directly to the pump, it will start and run but otherwise won't start.
      Any help to this old nubie will be greatly appreciated. My background is electronics, not vehicles.
      --Richard
    • By bmoody4550
      Hello,
      I have changed the battery , alternator and the regulator.
      I have the red battery light on indicating it is not charging.
      Is there something else that could be the problem to my battery not charging??
      Thanks
      Bill
    • By Buggs63
      Sometimes when I go from neutral to high, the machine will not move and I have to move the shift lever back and forth until it go into gear, and the strange part is when I go from reverse to high to low, it stays in reverse and I have to turn the machine off, move the shift lever a few times then I can start and take off in drive, please help.
    • By jdwalsh
      I was wondering if anyone has ever replaced the inner front CV boot on a 2007 Gator HPX 4x4 with a kit other than John Deere's WAAAAAAY overpriced boot kit.  It seems that there are numerous vendors on Ebay and Amazon selling the OUTER boot kit, but no one selling the inner.  I was up in the woods on my 40 wooded acres and tore up my right inner front boot and don't want to pay 3x the usual price for the green part.  If I get no help here, I intend to measure mine and see if I can get a more universal kit to work for me.
    • By Tn. Renegade Rider
      have a new actuator to install, but can't seem to get the old one off. Have removed the screw and can wiggle it freely, but cant get the tube and o ring that go to into the differential to come free. trying not to break it off in the process. Any suggestions besides more brute force?
  • Similar Tagged Content

    • By David Dewayne Reel Sr.
      Hi, I was hoping to find an "in-color" diagram, at least, of the wiring from the speedometer and where all the wires are connected.
      The entire wiring of the entire side-by-side would be wonderful!!!
      I purchased a used 2008 Joyner Commando 650 2 seater from an individual and they butchered the wiring...something has come lose and I cannot for the life of me tell where it is supposed to connect. It is a ground wire and is till connected to the frame but I don't know where else it is suppose to connect.
      What makes me think it goes to the speedometer is that when it came lose, the speedometer immediately stopped working.
      If anyone can help me with this, I would appreciate it tremendously. There is nothing on Joyner's website...and I already looked on YouTube to no avail...might be something there but I could not find it...
    • By Gorson
      does anyone have any knowledge of these clutchless automatic manual shift utvs? I have a 4 seater 4x4 650 that the wiring has been butchered and there is no longer a shifter knob. I'm just curious to know if anyone has a wiring diagram or any knowledge of these units without a clutch pedal and are electric shifted and not cable gear driven
    • By bmoody4550
      I recently got a 2006 Joyner 650cc Commando. It was not running when i got it.
      I put a new fuel pump and alternator and is up and running.
      My problem is when I originally got it started it seemed I didn't have 1st gear.  I was able to get it moving from 2nd and was sure I got it into 3rd.
      In my process of diagnosing the first gear issue and I realize I have first gear because it is where I thought 3rd gear was. But now I don't seem to have 3rd or 4th gear.
      The shifter itself seems sloppy and needs a little rehab if that is possible. Replacement available?
      Cables are worn so I don't know if they have too much play to properly shift. Can't seem to find any cables available to replace. 
      Can someone tell me which cable should be first and second and 3rd and 4th? One is black and the other is red.
      Ultimately it may be a transmission problem internally.
      As long as I have 1st and 2nd the machine will work for me going through the woods picking up wood.
      Any help is greatly appreciated.
      New to this if you can't tell.
      Thanks
       
       
    • By Nokie
      The rear gear box has a big hole in it were the drive line enters. The engine runs well and it has chrome wheels .
      what on earth should I do with it ?
      Any ideas would be appreciated !
    • By JeremyH
      I recently replaced my rear driveshaft on my 08 Commando 650.  Unfortunately, the parking brake rotor was welded to the old one, and the new one did not have one.  The folks at Joyner recommended just moving the caliper to the rear wheel as there is a second bracket I could mount it to.  However, the brake line is too short to reach that bracket, anyone done this reposition before?  Are there standard size brake lines and fittings that I can buy to move it?  Right now I have it bolted back up to the factory bracket but it sucks to not have a parking brake.


×
×
  • Create New...