Quantcast
Jump to content

Chris Watts

New to me 2008 Massimo MSU 500!

Recommended Posts

Good afternoon wanted to say hello I just picked up a nice 2008 MSU 500 for my kids/teens to drive around. Going to be scouring the forums and bugging a lot of people to get some hopefully easy questions answered. I keep getting told that a lot of the stuff/parts is interchangeable with rhino parts so hopefully that makes things easy if I need to replace items. Thanks for the warm welcome

 

aee815b96dc3bbb83b122262200d8412.jpg

Sent from my iPhone using Tapatalk Pro

  • Like 1

Share this post


Link to post
Share on other sites


Congrats on the purchase and welcome! Topic moved to Massimo UTV Forum. 

Share this post


Link to post
Share on other sites

Welcome to the site.. I truly hope you do not have the never-ending problems that so many are having with these  Massimo machines.. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, its older for sure but I put it through some decent work climbing hills this past weekend. I was impressed. Any things specifically I need to watch for?

Sent from my SM-G988U using Tapatalk

Share this post


Link to post
Share on other sites


mine as well as several others I have talked to , are plagued with constant overheating issues, resulting in blown headgaskets… and clutch/trans issues ..  Massimo admitted to me in email that these 500 and 700 HISUN engines were not good and they discontinued them, went to another Chinese Company  for engines .. But refuse to help any of us that were dumb enough to buy them.. I bought mine in 2018 new.. its been in shop 5 times , only has 300 miles.. I hope you have better luck. ….oh, and its in the shop right now.... HEAD GASKET 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks I’ll keep an eye out. Only issues I know of with 380ish hours and 1300 miles is fuel gauge not working and the winch. It took a beating last weekend and climbed some decent inclines for what it is. Any chance a 700 engine would work? My ecu in the hood says 700-4.



mine as well as several others I have talked to , are plagued with constant overheating issues, resulting in blown headgaskets… and clutch/trans issues ..  Massimo admitted to me in email that these 500 and 700 HISUN engines were not good and they discontinued them, went to another Chinese Company  for engines .. But refuse to help any of us that were dumb enough to buy them.. I bought mine in 2018 new.. its been in shop 5 times , only has 300 miles.. I hope you have better luck. ….oh, and its in the shop right now.... HEAD GASKET 





Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

Hopefully the previous owner  got all the problems worked out before you bought it.. .. enjoy it ..When mine actually runs, its fun to drive.. problem has been ,its in 20 minute increments, then back to the shop.. now I m waiting on a new Cylinder head to replace the cracked one mine has ..

Share this post


Link to post
Share on other sites

Thanks i hope so also, installing some rock lights and whip lights and a 32" led bar for the kids to have while the drive, this way ill always see them at night lol

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Joey Miller
      Hey I finally found a joyner I could afford lol I just bought a 2008 joyner sand viper 800cc I like it but it needs work that's not the issue me being a mechanic issue is I can't seem to find the parts I need like everything else I've worked on I'm not even sure what would work so I need advice from some one who has been there for now the things I need the most are rear shocks , I need the upper and lower ball joints or Johnny joints whatever they are called and I'm sure this had a fuel pressure regulator before now it just has some random inline pump no filter runs good for 15 mins or so then runs pretty crappy but if I let it sit a bit same thing I know it's going out but I need to know what I can do to sub for the factory pump and what psi requirement it has that's it for now any help would be appreciated
    • By Racer310
      1-Got  some clicking type noise as if metal to metal and sounds like it is coming from both front and rear A arms. They don't have anything their to grease except maybe take the bolt out and slide back in it?
      2-Also manual doesn't give a brand name for the oil filter or a cross reference to buy one at auto parts store.
      3-Air filter---where is it? manual I goggled has it in 2 different locations but NO air filter to be found. Maybe it doesn't have one.
      4-Love the buggy so far, got LED lights, stereo system, seat covers.......yep and got stuck mugging first time out but had a blast.
      Thanks
       
    • By Neil Wilson
      I just bought a 2008 Trooper T2 not knowing much about them. On this one the owner said the horn doesn't work, the winch never did work and during inspection the rear brake lights didn't work. He said he replaced the rear light pods recently and the brake lights worked before. He said the fuse module is corroded so he bypassed it and rigged up his own switches for the fuel pump and radiator fan. I see in the wiring diagram the horn and rear brake lights are on the same circuit. Now I am worried the problem is in the wiring harness.
      I have the wiring diagram from the online manual but I can't make any sense of it. I see lots of posts about wiring issues and I am feeling a bit overwhelmed with all the issues I see with these machines and am regretting buying it.
      For now my main concern is to get the brake lights working so I can drive it to some nearby trails. I would appreciate any advice on how to go about diagnosing the problem or workarounds. Also if there is a better wiring diagram out there that might help. I would consider hiring someone local to diagnose it so any recommendations are welcome.
      TIA.
    • By dmackey41
      I am looking for a pressure sensor for a 2008 rtv 500.EG672-44801
    • By Akovia
      The  dashboard display  shows a blinking “o”. Four wheel drive does not engage. The accustomed engagement sound is no longer heard. Has anyone a suggestion on where I might troubleshoot? Thanks. 
  • Similar Tagged Content

    • By Joe Breaux
      Got a 2017 Massimo MSU500 UTV with thermostat malfunction.. hot light comes on in 4-5 minutes but radiator is ice cold... where exactly is it?  The hose neck on the head has nothing in it.  I was told it was down by oil drain plug.. only thing I see is water pump.. Is in inside pump housing?  Cant find any exploded diagrams that show it.. how to I remove it? any help would be appreciated
    • By David Augusta
      I am wokring on a MSU 500 that ran out of fuel and now , will not start. Pump runs and the injector shoots out a good pressure. There is good spark. Valve clearance is correct.How much pressure does the  pressure release system release ? I am showing only 8 to 10 lbs  ( unless my guage is bad).  The unit was possibly submerged ; lots of mud on everything.  Any suggestions ???
    • By bamakid
      dose anyone know how to time  a 2015 Massimo msu 500 utv 
    • By Bluegill
      Hi. I replaced my coil and the ecu on my 2013 Massimo msu 500 and still have no spark. It has been a great machine so far but now I  am at a total loss. 


×
×
  • Create New...