Quantcast
Jump to content

Overlander

2015 Cub Cadet Challenger 500 didgital dash stays on..

Recommended Posts

After turning 2 batteries to water over last winter, I found that my digital dash display is staying on with the key removed. I was originally thinking the issue originated from the ignition cylinder but I'm now thinking its the ECU controller box under the hood. One of the unserviceable relays is making a weird sound when I remove the key. I have both batteries up to full charge and discovered the display issue last week when I saw the lights on in the dark.. Do any of you have any input on this issue? Ignition or controller.. Any help before just ordering parts would be helpful  The controller is $140  not sure on the ignition.. Thanks in advance..

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By GDS
      I have just purchased a 07 3010 Mule. It has high hours at 1900 but has been well taken care of. It seems to run well but just a bit weak. Every now and then I hear a clinging sound that may be a ignition spark to ground but I can't seem to find it. It will not do it when I'm looking. Also the back plug is showing its rich. It is black in no time where the front is a lite brown. 
      I did find it had the wrong plugs so I changed them, but no help. 
      As I have just got this I was wondering what do I need to look at as far as simple mods or weak points. 
      Thanks for your help
    • By Michael Kinlaw
      I have a 2016 R4 and I was about to load it on my trailer and the steering just broke I think. My front wheels are both pointing outwards. Does this mean front differential broke?  I jacked it up and got them both pointing in the right direction. When up in the air they work together. But as soon as I put back on the ground and move it a few feet they separate again. 
    • By downrb92
      I have a Joyner 650 San spider looking for ignition switch with keys



    • By groged67
      I have an issue with my sector crew 750
       2017 EFI
      Starter engages and spins but does not turn the engine over. Does this mean a bad starter clutch. The starter is new. I started the pull of the cover where the starter clutch is located but cannot get to the back bottom bolts.
       
      Any help would be greatly appreciated!
       
    • By Brokebuggy
      OK here goes.  I have a cub cadet volunteer with a fuel injected Kohler lh775.  This was brought to me from another shop since they couldn't figure it out.  
      Here's their story.
      came in for a water pump.  tech pulled the intake and a few other misc parts and replaced the water pump.  Reassembled and the motor was missing on cylinder 2.  replaced several parts and just couldn't get it to run on both cylinders.
       
      So in my shop we checked compression 155ish on both cylinders at wot.  I can get the motor to start if I hold the gas pedal in just the right place but at low RPM's it very rough.
      Pulled side cover and verified timing is correct and key ways are not sheared
      turned over motor with injectors out and they spray evenly and the same. best I can tell by eye
      installed new plugs and got motor to start and held it at higher RPM's for a few seconds.  cylinder 1 plug is dark cylinder 2 is still new and seems  damp with gas
      switched coils from 1-2 installed new plugs again and same test with same results.  
      The other shop replaced the ECU and harness.  No matter what parts I switch from cylinder 1 to cylinder 2 the problem stays on cylinder 2.  
       
      Any thought or ideas would be greatly appreciated  
  • Similar Tagged Content

    • By NewCadetOwner
      Hello everyone.  I purchased a 2017 Challenger 750 eps Crew with 400 miles and find the exhaust noise is awful.  I saw in another post chatter about a 2019 exhaust upgrade?  Anyone have info on this?  I also would like to know the typical RPMs for speed.  I am running 4k at 20mph in hi range and it seems like it does not have the power I expected.  
      So far I have added a custom mount rear winch, soft rear window and upgraded LED headligjt bulbs.  I am looking for any other upgrades people have done.
       
    • By Chris Howland
      Hi all, Im looking for the valve clearance specs for a 2017 cub cadet challenger 750. Any help would be appreciated.
       
    • By Verno
      I installed the 2019 exhaust upgrade yesterday.  Overall went very well, but my rear driveshaft / u_joints are extremely hot.   Is there some sort of heat shield that should be added.  TIA for any input
    • By Larry Black
      My 2018 challenger 750 needs rear shocks, are there any aftermarket ones available that aren't $350 each??
    • By Gary T
      I generally use my challenger for light duty misc. use, and for plowing. The one thing I dislike about this machine is the difficulty in shifting. I've had it the shop and they adjusted the shifting lever, but I still have issues. Some times it shifts ok, but the problem is it is hard to get it to move the lever from high to reverse or low to high or from any gear to the other. Seems I always have to accelerate a little to get it to engage to what gear I need it to go to. This is definitely not normal.


×
×
  • Create New...