Quantcast
Jump to content

Gorj

Hisun EV LED light bar

Recommended Posts

I just installed a 12" LED light bar on my Hisun EV. Wow a difference it makes at night!

Hisun EV light bar.jpg

  • Like 1

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By j.fulciniti
      Hello Folks - newbie here with my first post so go easy on me.  I picked up a Buck 400 in May 2020 direct from Massimo when they were doing a closeout sale on the 400 models.  I read the reviews and was skeptical. 
      We live in a golf cart community  we do not plan any off roading - just some very mild work tasks like hauling firewood / brush etc.  Honestly, all we do is cruise around our neighborhood roads.  I pulled the trigger b/c the price was cheaper than a 2WD lifted golf cart and the Buck  had way more features.
      We have a few steep hills and after about 20 - 30 minutes of cruising, my check engine light comes on.  It only happens when we are going up or down one of the hills .  We head straight home and things seem fine the next day.  Light never comes on unless we tackle multiple hills during one ride.
      Should I be worried?  
      PS - Unit is 4 months old and has 258 miles on it - barely broken in.  I've yet to go full throttle on a flat or up a hill. 
    • By Osney
      I have a HiSun Vector E1 (as they're called here in the UK) and have been running it for about a year now. It has an annoying problem that my dealer has not yet managed to fix.
      On a full charge, at the start of the day, it works fine - albeit not the quickest machine in the world. I use it on my hill farm here in Scotland, and it has to climb a bit, although nothing that would leave you out of breath walking. The E1 copes with these hills no problem, until it's done about four or five miles, then it starts to struggle noticeably, and throws of the 4C53 error on the dashboard readout - low voltage according to the manual. Sometimes it does this even while the charge level indicator is showing a full charge.
      It's been back to the dealers twice now, and they've replaced all of the batteries. I've emailed the UK distributor for HiSun in the hope of an answer, but as yet have had no response. My dealer is trying to get an answer from them too, before taking the machine back to try and fix it again. Meantime I can only use it for a short while each day.
      I'm no electrician, so has anyone on here any idea what might be going on? It seems that it is struggling to draw enough power from the battery pack going uphill, leading to a voltage drop that trips the error code. But if that's the case, then the E1 is surely not fit for purpose.
    • By Gorj
      Do not know if any of you Hisun E1 owners have  had issues with the parking brake pedal  not returning completely, thus preventing you from moving forward or reverse.   I had this issue and even sometimes when going over rough road the parking brake pedal would move down far enough to shut off power.  Local  dealer said no one had complained about that issue and they had no fix.  So decided to correct it myself. I installed a return spring on the parking brake arm and it stopped the problem!

    • By mcraigchr
      Howdy all,
      I searched the forum (and the internet in general) for this and didn't find anything that looked like an answer.
      I purchased a Coleman 550 from Tractor Supply last October.  Runs well.  Really only one issue that I have had and that is a dragging brake pad.  Still haven't fixed it, but hope to soon.
      For now, it is time for the first oil change (38 hours).  After some reading, I decided to use Mobil 1 4T 10w-40.  I also purchased a filter from motorcyledoctor.com.  Got the filter and noticed that there is a hex head on the end.  I thought "Hey that's nifty, but I wonder why they did that?".  Then I went to change the oil and I know why now.  Which brings me to my question.
      How in the hell is one supposed to get that oil filter off?  First off, it is not obvious how to take the seat base out to get leverage.  I thought about cutting out the plastic above where the filter is.  But decided against it for now.  I tried my best to work within the tiny space given to get the filter out.  I have a number of different filter wrenches.  Only one is able to fit over the filter.  But ... I could not get the filter to break loose.
      So, I ordered a strap wrench from Amazon.  
      https://www.amazon.com/gp/product/B01MZH57V5/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1
      In case that doesn't work, I also ordered this:
      https://www.amazon.com/gp/product/B07FVNH2QV/ref=ppx_yo_dt_b_asin_image_o01_s00?ie=UTF8&psc=1
      My intention with the latter is that if the strap wrench does not work, I will punch a hole or two into the side of the second product.  Put it over the end of the filter, put two screws into it and hope I can break it loose.
      Anyone else experience this incredibly difficult task?  I have always worked on my own vehicles and have had some difficult circumstances, but I always prevailed.  Not this time.  The Coleman 550 b*tch slapped me this weekend and is pointing and laughing at me.
      Any suggestions or recommendations would be great.  If nothing else, just some content on the subject so that someone else who might be having the same issue can find this and get some ideas.
      Thanks,
      CC
    • By rtate1050
      I recently ordered some parts for my 2017 MSU 500 and when they came there was a brochure included that gave some hints for making Hisun motors run better . Most of them made sense but one suggestion was to raise the oil level by 3/4qt. (bottom of dip-stick threads) to improve wet shoe clutch wear . I'm not yet familiar with the power train on UTV's (but I'm a-larnin') but this goes against what I was always taught about overfilling oil levels. These guys seem to know their stuff (Motorcycle Doctor ) but I'm wondering if anyone has any input on this .
      BTW...They did have one good suggestion about blowing all of the old oil out of the oil cooler when doing an oil change.  When doing an oil change on my cars, this is something that I've always done ( I was taught by an old school mech. MANY yr=ears ago) but is rarely ,if ever , done in a garage. You'd be surprised at the amt. of dirty oil that you avoid adding to your fresh oil. Just remember to recheck oil level after running the engine and top off the oil.


×
×
  • Create New...