Quantcast
Jump to content

2wpuller

Info on aftermarket shocks and springs.

Recommended Posts

Has anyone replaced the stock shocks and springs on their 2015 Dominator 800 X2 to ride alittle smoother are just changing the springs out.I gotten alittle spoiled riding in my son's rzr 1000xp.

My wife just made a comment why don't ride as smooth as our son's thing.lol

I'm 62 she's 61 the little rough ride doesn't really bother me. I drive a concrete mixer for a living. 

I really like the Odes it's pretty good power for for only 800cc

I took off the cat and the stock muffler. Put a glasspack with 2" inlet and outlet it has a good deep tone and not really very loud. I'll find out Sunday when we hit the woods .It's definitely more peppy. 

Share this post


Link to post
Share on other sites


On 9/15/2020 at 6:03 PM, 2wpuller said:

Has anyone replaced the stock shocks and springs on their 2015 Dominator 800 X2 to ride alittle smoother are just changing the springs out.I gotten alittle spoiled riding in my son's rzr 1000xp.

My wife just made a comment why don't ride as smooth as our son's thing.lol

I'm 62 she's 61 the little rough ride doesn't really bother me. I drive a concrete mixer for a living. 

I really like the Odes it's pretty good power for for only 800cc

I took off the cat and the stock muffler. Put a glasspack with 2" inlet and outlet it has a good deep tone and not really very loud. I'll find out Sunday when we hit the woods .It's definitely more peppy. 

If you have the black end shocks with gold body and red spring those are rebuildable and revalveable, But with that said usually they are just low on nitrogen or don't have any nitrogen left in them.

Share this post


Link to post
Share on other sites

I picked up a set of 4 rzr 800 shocks and springs  . We got front put on and wow what a difference. 2 of us pushing Down on the front bumper couldn't get it to give maybe a 1/2 "

The rzr springs are just like when I pressed down on my son's rzr 1000xp. 

I only lost 1/2" of ground clearance down to 12" my steering rack came in today .I'm making new mounts for a rzr rack. Mine broke last week. Broke the mounting tabs off the rack and the frame mounts bent. They were bent when I got the machine. I'm going with hiem joints also. Have extra parts from my son's rzr. We are adding 3 " to the wheel base by use 2018 Yamaha wolverine rear A  arm very little modifications to use them just my opinion. My soninlaw had a new set he has extra. 

20201011_153326.jpg

20201011_153053.jpg

20201011_153102.jpg

20201010_195054.jpg

  • Like 1

Share this post


Link to post
Share on other sites


Rear has 12.5 " of ground clearance now. Had to raise the bed up 3" to clear the shocks. Also moved the bed ram bottom mount to the rear by the back part of the frame. We put a new crossmember in replace of the original shock crossmember because we had to cut it to align the frame.I guess mine was made on a monday after the welder had a bad weekend. Lol the upper frame was out of square. The machine dog tracked bad. Didn't notice it when I bought it..  Soninlaw is a great body man very good at what he does. Still have to make the plate that bolts to the Aarm bushings bolts to hold them in 0place after alignment. 

Hopefully this week we'll get the Polaris steering rack and EPS on. The original brackets for the rack is bent up and twisted up. The new one definitely will be stronger..

20201017_115426.jpg

20201017_190412.jpg

20201017_190423.jpg

20201017_190449.jpg

20201017_202115.jpg

20201017_202832.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By miten000
      Hey guys...I have a 2015 ODES Dominator X4 800cc...I had recently tore the belt up and was able to get a new one on and had no problems.  The other day I got stuck and smoked the clutch out a bit trying to get out and since that time I have had a constant "clicking" noise coming from the primary clutch.  Then noise is present at idle and low speeds but goes away under load.  I took the clutch apart and assume that this noise is coming from either the clutch sliders/weights or shoes.  I plan on replacing these soon.  
      However, today I put the clutch back together to get the bus out there and ride around the neighborhood and I have a "jolty" start and while cruising in "H" the secondary clutch suddenly opens wide and I lose power.  When revved the secondary clutch will not grab and continues to open.  I can place the UTV back into "N' and then back to "H"...the secondary clutch stops spinning and the belt grabs as normal and I can continue on.  Anyone have any idea what is going on or have experienced similar problems?
      https://drive.google.com/file/d/1bR6kVo2QsB6e6G6NK3jWjAoQpJCmeyVf/view?usp=sharing
      ODES clutch problems.mov
    • By petejank
      Anyone know of an aftermarket shock that fits a Arctic Cat Prowler 2006 650 H1 4x4?
      The direct replacement isn't currently available and costs $170.00  ea.
    • By johnpeter
      2015 Polaris RZR XP 1000 eps On Ebay
      https://www.ebay.com/itm/2015-Polaris-RZR-XP-1000-eps/284035887180?

    • By Barry E Spires
      I have an issue with my odes. It will start up and run but when you give it gas it stumbles and cuts off. I have replaced the fuel pump,fuel filter, fuel injectors, mass air flow sensor,idle air control,throttle position sensor,air filter,spark plugs,and throttle body also I have no vacuum leaks either. I have even replaced the ECU. Does anyone have any idea about what could be wrong? Engine only has 1045 miles on it
    • By miten000
      What aftermarket belt do you all use that fits...my dealer used the DAYCO XTX 2236...???


×
×
  • Create New...