Quantcast
Jump to content

Mackc

new to massimo buck 400

Recommended Posts

Hello, I'm back from Kawasaki  2004 3110 Mule land and now am struggling thru the Massimo Buck 400 swamp.  I bought a 2019 Buck 400 with 200 hours on it and am going thru the owner's manual. I have noticed a couple of things needing addressed after driving it home.  I t is rough starting off, like maybe the drive clutches and or belt are not exactly right. also the parking brake is a question mark.  The manual shows (seems to me) that pulling the handle down should disengage the parking brake, not this one,  pulling up disengages the parking brake, also the handle is really hard to move while holding the super strong button.  The handle will only go down a smidgining past half way.  Do I need to work on this?  This old man will ask for help in a NY minute! please stand at ease, I' will be in the area.

Share this post


Link to post
Share on other sites


my condolences on buying anything Massimo.. we have all been thru the nightmare that is Massimo  Motors problems.. Mine has been in the shop 6 times just this year.. Only one shop in my entire state will even work on them.. and Massimo wont cover warranty at all

Share this post


Link to post
Share on other sites

@Mackc How jerky is it starting off?  My 2020 was smooth brand new and within 50 miles developed  a jerk when starting out but only really noticeable when the unit is on a cold start.  After a few minutes the transmission smooths out.  I haven’t pulled the belt to verify wear but as it’s primarily an issue when cold I’ve assumed that’s probably normal.

My parking brake is the same as yours.  Up is released and down is set.  As long as it is completely setting(holding the machine) when halfway down and completely released when up it sounds to be adjusted properly.

Share this post


Link to post
Share on other sites
4 hours ago, dweaver said:

@Mackc How jerky is it starting off?  My 2020 was smooth brand new and within 50 miles developed  a jerk when starting out but only really noticeable when the unit is on a cold start.  After a few minutes the transmission smooths out.  I haven’t pulled the belt to verify wear but as it’s primarily an issue when cold I’ve assumed that’s probably normal.

My parking brake is the same as yours.  Up is released and down is set.  As long as it is completely setting(holding the machine) when halfway down and completely released when up it sounds to be adjusted properly.

Good news about the cold start being jerky,  I had seen the buck 400 here at a distant neighbors place when he bought it at TSC, also in a few months his twin sister next door also bought one after they moved here from out of state.  Both of the Buck 400 have been used daily without problems, I

I bought the one  from the guy (distant neighbor) for what I saw as a good price, I didn't have to drive 100 miles to pick it up or wait until TSC got a any available nor have to pay sales tax on it. 

It has 200 miles on it and is only 1 year old, his wife didn't like the noise, they used the money to buy a, older used gas powered Club Car

One thing is for sure, Websites on Dot com always look really great......Then we check out the real world on UTVBoard forums. 

Share this post


Link to post
Share on other sites
On 9/20/2020 at 9:48 AM, Joe Breaux said:

my condolences on buying anything Massimo.. we have all been thru the nightmare that is Massimo  Motors problems.. Mine has been in the shop 6 times just this year.. Only one shop in my entire state will even work on them.. and Massimo wont cover warranty at all

 

On 9/20/2020 at 9:48 AM, Joe Breaux said:

my condolences on buying anything Massimo.. we have all been thru the nightmare that is Massimo  Motors problems.. Mine has been in the shop 6 times just this year.. Only one shop in my entire state will even work on them.. and Massimo wont cover warranty at all

Thanks for the condolences! BTW I worked in New Iberia  as a Resource Manager Analyst for Halliburton back in the 1980s and 1990s

Share this post


Link to post
Share on other sites


I noticed in the manual that 10 W40 motor oil is recommended, but having a wet clutch isn't a special oil like for motorcycles needed what oil should be used also with no spin  on oil filter. I have Quaker State   30wt that I use in my riding mowers. Is it okay for the Massimo Buck 400 S?

 

 

 

Share this post


Link to post
Share on other sites

I use 10w40  Castrol ACTEVO Part Synthetic motorcycle oil for wet clutches   You can use any conventional or blend  for wet clutch ..... I would not use a full synthetic in a wet clutch 

Share this post


Link to post
Share on other sites

Has any of the members here on the UTV Board ordered parts from Excalibur  Motorsports  in Calif. on Ebay?

I saw that they have a lot of parts, I was looking for a remote switch for the Buck 400 winch. 

Share this post


Link to post
Share on other sites

Okay here I am again....

I been reading the Buck 400 Service manual, well kinda trying to interpret it some and I was looking at the FUEL pump and saw a reference to the OIL PUMP pipes and OIL seal . What does the oil pump (maybe oil pressure?)  have to do with the Fuel Pump and fuel tank?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By johnpeter
      2019 Polaris RZR XP 1000 4 seat On Ebay
      https://www.ebay.com/itm/2019-Polaris-RZR-XP-1000-4-seat/114459460108?

    • By CAPTAINSTARFLEET
      Greetings all
       I have a 99 kawasaki mule 550  kaf300c3 That I ordered new valve guides for. Problem is my valves don't fit in new valve guides. Part number is correct. 
       Is it possible that valve guides need to be installed and reamed before the valves will fit into the  guides?   Just seems like an awful lot of material to have to remove by reaming.
      Thanks for any help
       
    • By jonny L
      Went for a nice trail ride for about 20 miles, came back, shut it off, and attempted to go for another ride. The electronic gear shifter will not go into park to start it up.  It reads neutral in the park position. Disconnected the battery and reconnected and it now read Park. But, when you put your foot on the brake to start it, it goes right back to neutral. Checked everything that I could think of and decided it has to be the 17 gear position sensor. Not certain this is the issue but I bought a used one on Ebay (could not locate a new one) and will try it. Any other possibilities?
    • By rjfrider
      Mule Pro MX question:  Is there a trick to removing the center floor panel or "tunnel" other than removing the 8 plastic rivets?  I removed the rivets but the panel won't pop up easily, and I don't want to force it with a crow bar so as not to break some tabs or other hidden parts.  Accessory mount instruction attached.  Thanks for your help.  rider
      Mule Pro MX floor tunnel.pdf
    • By Brando hart
      Please help, About to buy a new 2020 mule 700 MX. For driving back to my cottage which is only accessible by a 5 km off-road trail. My parents currently have a 2010 teyrx which does the job for a joke. The trail is fairly smooth -1 big rock Rock section that you have to climb. A big  rtv 1100 Kabota does it no problem as well. 
      I am looking into the mule because of its bench seat. One of my dogs cannot run in front because they’ve had a hip replacement. she also has anxiety and is not fare well on the teyrx. We think mainly because she can’t get comfortable because of the centre consul. We were thinking because of the mules bench seat she would be able to sit comfortably between me and my wife.
      my concern is the mules off-road capability. Do they fare pretty well in the woods/decently smooth ride?
      I also plan to do yardwork and plough my driveway with this mule MX. I love the size of it as well, Because it will be easy to store in my shed plus tow behind in my SUV.
      please let me know what it’s like in the woods/snow (in Nova Scotia we mainly only have 5inchs Of snow fall on the ground at a time)
      please help, me with Determining its off-road capabilities. determining it’s off-road capabilities and keep In mind the trail is in good condition. Also my 700 Yamaha raptor, and 400ex use to do the trail amazing. To give an idea that the trail of pretty good.
  • Similar Tagged Content

    • By KenL
      I've looked long and hard and can't find an oil filter.  Wondering if there is one.  Any help would be much appreciated.  Also, live in Canada - we have no Massimo service centers or dealers, only HiSun.  Are HiSun and Massimo related?
    • By Richard Schleper
      I have a new Buck 400 with about 60 miles on it. It runs great but can only get it up to 23mph. Is this normal? If not what speed are others gettting.
    • By greendw100
      I have a Massimo 400 Buck that won't start. When I turn the key, I get nothing, no lights, the meter doesn't light up, etc... I replaced the ECU and everything lit up, it cranked perfect, ran for a couple of minutes and shut down again. I have tried calling Massimo, they are pathetic, have been waiting a week for a return call. Any idea where to look? 
    • By Ron Puma
      Hi,
      I just purchased a used 2019 Massimo 400x Buck/golf version and wanted to know if anyone knows where to get an extended roof?
    • By MitchSpence
      My Massimo 400 Buck jerks and surges in reverse when cold. Help! Only 60 miles on it.


×
×
  • Create New...