Quantcast
Jump to content

Jonathan Wallace

2015 can am maverick check dps code

Recommended Posts

I have 2015 can am maverick 1000r xds turbo. It sat for a month and everything was fine when I parked it. I went to start it last weekend and the check engine light popped up and the check DPS code scrolls across the dashboard.

Share this post


Link to post
Share on other sites


Well I found out the 40 amp fuse is blown. I have put a total of three 40 amp fuses in and as soon as it touches it blows. What do you guys think I should try next.

Share this post


Link to post
Share on other sites

i would  check for continuity  on the wire it protects, from the wire to ground just in case any insulation has been wore off.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By johnpeter
      2018 Polaris RZR 4 Turbo On Ebay
      https://www.ebay.com/itm/2018-Polaris-RZR-4-Turbo/164524898583?

    • By johnpeter
      2018 Can-am Maverick X3 Turbo On Ebay
      https://www.ebay.com/itm/2018-CAN-AM-MAVERICK-X3-MAX-TURBO-4-DOOR-5-SEATER-UTV-ATV/324373669869?

    • By johnpeter
      2017 Polaris 1000 4 seater Turbo  On Ebay
      https://www.ebay.com/itm/2017-Polaris-1000-4-seater-Turbo/224228870318?

       
    • By Brad G
      Timing chain broke. Replaced the timing chain, oil pump chain, cam & rings. Ran great for 2 hours. Brought it home, started & drove to the shop. Next day started & drove around the property and it started running rough, wouldn’t idle just died, restarted & took it to the shop. Next day wouldn’t even start just crank over. Drained all the fuel & replaced with new, bought a new plug & ecu! Fired right up and let it run for an hour & burped the coolant as I had double checked the timing & valves prior. Next day started it and it was running a bit rough but smoothed out & ran for another hour. Next day it just cranks & won’t start! I’m at my wits end with this machine and would appreciate any help or suggestions on what might be the issue. Thanks in advance! 
       
      Brad
    • By Brent Wilson
      Hey guys. I am pretty new here but I came up with a crazy idea and executed it. I put Hoosier drag racing slicks on my '21 Turbo S Velocity and went to the 1/8 mile drag strip lol. I have a stage 6 tune and a bunch of Aftermarket Assassins stuff. Anyways, thought I would share. YouTube below. Racing is at the end at the track and vs a heads/cab truck on street.
       
       


×
×
  • Create New...