Quantcast
Jump to content

Logan

Polaris ranger xp Fire in air intake

Recommended Posts

Ok so I have a Polaris ranger xp 08 I think . I started it up no problem( never had any ) drove it out of the garage about 15 feet and let it idle for about 5 mins . Then it started to sputter , gave it some gas and it stalled out. Tried to start it a couple times but wouldn’t go. I figured gas was low, put some in but same thing . So I got the ether and took the air filter off sprayed it in and it fired right up but would stall out instantly.  So I tried it again and gave it some gas but same thing . Next I just sprayed and jus got enough to gas it back into the garage . But then I saw flames coming out of the air intake . Was able to put it out quick ( 10 seconds) just by blowing on it . Before anyone says to much starting fluid I know a little goes a long way . I didn’t hold it down and jus spray , only a quick burst twice before stalling out . But where do I go from here ? Engine not getting enough gas ? But then why was I able to start/drive/ and idle at first ? Now I can’t even get it started . Let me know what you think.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By johnpeter
      2018 Polaris RZR 4 Turbo On Ebay
      https://www.ebay.com/itm/2018-Polaris-RZR-4-Turbo/164524898583?

    • By David Trost
      Interesting problem.   My Massimo runs great - but when the fuel level drops just a bit, it just stops.    It restarts easily, but I have to keep my foot on the accelerator pedal.   When I top it off with gas, it again runs fine.   I already replaced the fuel pump, but that didn't work.
      Thanks for your help!
    • By johnpeter
      2017 Polaris 1000 4 seater Turbo  On Ebay
      https://www.ebay.com/itm/2017-Polaris-1000-4-seater-Turbo/224228870318?

       
    • By johnpeter
      2017 POLARIS RZR S 1000 EPS AND EBS On Ebay
      https://www.ebay.com/itm/POLARIS-RZR-S-1000-EPS-AND-EBS/184523221339?

    • By Brad G
      Timing chain broke. Replaced the timing chain, oil pump chain, cam & rings. Ran great for 2 hours. Brought it home, started & drove to the shop. Next day started & drove around the property and it started running rough, wouldn’t idle just died, restarted & took it to the shop. Next day wouldn’t even start just crank over. Drained all the fuel & replaced with new, bought a new plug & ecu! Fired right up and let it run for an hour & burped the coolant as I had double checked the timing & valves prior. Next day started it and it was running a bit rough but smoothed out & ran for another hour. Next day it just cranks & won’t start! I’m at my wits end with this machine and would appreciate any help or suggestions on what might be the issue. Thanks in advance! 
       
      Brad
  • Similar Tagged Content

    • By Susan Thompson
      Hi everyone, new to UTV life. My 2010 500 EFI has problem with re setting  maintained light and also hour meter. Have read manual and cannot find out how to re set after oil change.
    • By jwienrich
      HI new to the forum so this is my first post and problem. So I have a 2005 Ranger 500 6x6 with a carb and do not have any power to the fuel pump. Research has suggested that it could be the pdm but after looking extensively through my machine I cannot find a pdm. I can only find 3 flat black thin boxes under the hood on the passenger side. Are there some ranger 500's without pdm's? I bought this machine new and it has never been messed with. This machine has been in storage for several years and has only 12 hours on it.
      Thanks, Jeff
      My Bad just looked at my title and its a 2004 not a 2005 so no PDM or ECM. Wiring is quite different so I need to take another look.
    • By Hoytlifer
      I have a  2019  Ranger 900 XP EPS that I would like to change the factory headlights to LEDs.  Has anyone done this, if so what style of bulb was used.?
    • By Lester Richards
      Took it out the other day, it died and engine temp light came on and I heard the gurgling in the radiator. I let it cool for few, got it home in limp mode.  fan kicks on but im not sure 40 seconds is long enough and/or if it kicking on all the times when it needs to be. fan relay works id assume or fan would never operate. Took temp sensor wire off and fan does NOT auto kick on like I was told. No debris in front of radiator, its full , correct level on overflow tank. unit has 1,600 miles, iv had if for 6 months and all the sudden I get this issue.
    • By Brett
      Fuel injected 700 starts great and idles great but touch the gas and it dies


×
×
  • Create New...