Quantcast
Jump to content

2012 hisun hs 500, Not starting


Recommended Posts

Hi, new member here, thanks for the ad. Our 2012 hisun hs 500 utv turns over but won't start unless primed. It'll run then for a few seconds & shut back down. It's just not getting fuel. Things we've done, installed brand new fuel pump, fuel pump relay, starter selonoid, replaced all the small fuses in fuse container...10-15 & 3 amps. Replaced a few Butt Connectors a 30 amp. Fuse for headlights. Tapped up some electrical wiring. Nothing has helped. It always started instantly. At a loss as to what to do next. Any suggestions would be so appreciated. TIA. Ann 

Link to post
Share on other sites
  • 1 month later...

I sure will. As of Saturday, the mechanic was looking into ordering a new wiring harness for the hisun hs 500. Said it'd save us money in the long run, rather than him chasing wires to find the issue. I'll update my post if we ever see it again,hits going on 6 weeks now😞

Link to post
Share on other sites

interesting i was having hell with mine with electrical issues finally found a gasket on the 18 pin connector into the fuse relay box was preventing the connector from  fully engaging causing a loss of ground though out the whole utv i pulled the gasket out lockwired the connector in place and it runs like a scalded dog now...i dont plan on running thru any water that high so....lol

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By mcraigchr
      Howdy all,
      I searched the forum (and the internet in general) for this and didn't find anything that looked like an answer.
      I purchased a Coleman 550 from Tractor Supply last October.  Runs well.  Really only one issue that I have had and that is a dragging brake pad.  Still haven't fixed it, but hope to soon.
      For now, it is time for the first oil change (38 hours).  After some reading, I decided to use Mobil 1 4T 10w-40.  I also purchased a filter from motorcyledoctor.com.  Got the filter and noticed that there is a hex head on the end.  I thought "Hey that's nifty, but I wonder why they did that?".  Then I went to change the oil and I know why now.  Which brings me to my question.
      How in the hell is one supposed to get that oil filter off?  First off, it is not obvious how to take the seat base out to get leverage.  I thought about cutting out the plastic above where the filter is.  But decided against it for now.  I tried my best to work within the tiny space given to get the filter out.  I have a number of different filter wrenches.  Only one is able to fit over the filter.  But ... I could not get the filter to break loose.
      So, I ordered a strap wrench from Amazon.  
      https://www.amazon.com/gp/product/B01MZH57V5/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1
      In case that doesn't work, I also ordered this:
      https://www.amazon.com/gp/product/B07FVNH2QV/ref=ppx_yo_dt_b_asin_image_o01_s00?ie=UTF8&psc=1
      My intention with the latter is that if the strap wrench does not work, I will punch a hole or two into the side of the second product.  Put it over the end of the filter, put two screws into it and hope I can break it loose.
      Anyone else experience this incredibly difficult task?  I have always worked on my own vehicles and have had some difficult circumstances, but I always prevailed.  Not this time.  The Coleman 550 b*tch slapped me this weekend and is pointing and laughing at me.
      Any suggestions or recommendations would be great.  If nothing else, just some content on the subject so that someone else who might be having the same issue can find this and get some ideas.
      Thanks,
      CC
    • By oakhill
      I purchased a 2015 Hisun HS500 UTV used, and the only thing wrong with it is the fuel gauge does not work.  When the fuel pump is in the tank, the gauge always reads empty.  When I remove the fuel pump from the tank and manually move the float, the gauge works as it should.  When the fuel pump is in the tank, it sounds like the float is hitting something in the tank.  I checked the tank and there seems to be no obstructions in the tank.  I figured the float arm was too long so I cut 1" off the length of the rod and reconfigured the float.  I put it back in and the same thing happens:  the gauge shows "empty".  I have made sure the fuel pump is in the proper direction with the inlets pointing toward the driver side and the electrical connection is pointing toward the front of the vehicle.   We don't have a Hisun dealer locally and all the dealers away from here, including the plant in Texas, have no suggestions other than what I've tried.  Please help.
    • By Lance Darbonne
      Massimo 500 wont start.  Pulled the injector and when i turn the key it sprays a lot of fuel, but the spark plug is dry.  What would be my next step?  Valve adjustment?
    • By Dukhntr
      I have a 2017 500 Massimo that is weak like will not spin a tire in a good mud hole. Does anyone know how to boost power. A friend told me of a chip to bypass emissions.  Has anyone tried the chip or have a suggestion.  Thanks in advance. 
    • OEM Parts at Aftermarket Prices
    • By Robert Nelson
      2020 Hisun sector 1000.
      I've got about 40 hrs on it the speedometer stopped working.when I start the engine, the speedometer go's all the way over and back.like it should,but doesn't move while the utv is moving at any speed.. suggestions on what could cause this,thank u.

×
×
  • Create New...