Quantcast
Jump to content

Anyone running a Subaru EH65 engine?


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Fib103182
      I have owned my 2015 Hisun HS700 Crew  for about 3 or 4 months now. I got it used and was supposed to run good but was not put all the back together from a stator upgrade due to previous owner said he was going to out a stereo system on it. Anyway I have worked it much more than I have rode it. I seem to work on it 2 days and ride it for a hour. Me, my wife, and 2 kids (10 and 18) enjoy it but the engine compartment gets so hot. I've replaced the water pump and burped the cooling system and any other thing I could think of to bleed the air out and think its good with no air and water circulating. Fan seems to run fine and be on about all the time. Changed the coolant twice and oil 3 times. I noticed the engine really has nowhere for heat to go because heat rises and no air flow at all. Has anyone had any experience in this area? Any DIY tricks or any advice in removing the heat out of the engine compartment and getting it to a tolerable temperature. Im about to sell it if I can't figure something out and go waste money on a big name brand but I won't have red legs and arm from engine heat burning me and my wife. They machine never acts like its to hot or anything but it feels like it is. Thanks in advance for any and all help. 
    • By jsm2006
      I have a 2012 yardsport 700xlt that started with a high idle, I changed out the throttle body but it was still too high. I then messed with the throttle cable positioning and now it will run for about 30 sec. and then as soon as I touch the gas it sputters and dies like its getting too much gas. I've changed out the filters and checked the pump. It could be something completely else but a mechanic told me to reset the engine management system but all I know to do is take the battery cables off and touch the 2 ends together. 
    • By Eric Nelson
      The machine will not idle. I have to hold the gas pedal down for it to start. If I do get it in drive I can be going at full throttle and it will bogg all the way down almost to the point of dying and then it will recover and the do it again over and over. If i stop and take my foot off of the gas it dies. Common problem? Suggestions?
    • By GrimSinner
      This is my 2013 Teryx FI 4x4 LE.  It recently started this knocking that was loudest on the clutch side, so I removed the cover and took a video.  You can hear it best at low throttle.  What is causing that and what should I start repairing?
      Thank you.
       
    • eManualOnline
    • By Amyjou
      Our 2017 Textron Stampede 900 died when driving it (after making a terrible noise).  Now it won’t start. Checked oil and there wasn’t any.  Was given advice that the engine would need to be replaced. Trying to find a used or rebuilt one.  Any recommendations or leads on how I can find one?

×
×
  • Create New...