Quantcast
Jump to content

2013 Odes Dominator 800 UTV won’t start


Karma
 Share

Recommended Posts

I am having a problem my 2013 Odes Dominator 800.  I have changed the spark plugs, cleaned the air filter and fuel filter. The battery is new and the motor turns over. If I use a touch of starting fluid, it starts up and runs great. Even after running for a while and being warmed up, it still will start again. I was wondering if anybody would have an idea if I have an electrical problem or a fuel problem.  Thanks!

Link to comment
Share on other sites

  • Alex changed the title to 2013 Odes Dominator 800 UTV won’t start

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

  • Similar Tagged Content

    • By Kirk Falk
      Hello,
      I have a 2018 Dominator LT 1000 and I am wanting to stiffen up the ride.  What is the best way to accomplish this, tighten the recoil spring up or add air to the shock.  I can't find any information on the procedure.  Also, since im asking questions........my top end rpms doesnt seem to be where it should be.  Max RPM is 6100 and usually drops down to 5800 maxed out.  Im just wondering if everyone else has the same experience.
      Thanks,
      Kirk Falk

×
×
  • Create New...