Quantcast
Jump to content


New member in Northern Michigan


Recommended Posts

Just bought my first SxS 4 days ago. Looking forward to hitting some trails and back roads. Having a few issues with the machine(Vector 500), but nothing serious. Just setup and tweaking. I would like to by some accessories, but I don’t seem to be able to find much which is machine specific. Or at least my machine. Does hisun offer accessories? Any advice would be appreciated. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By BernieG
      I could really use some help identifying some disconnected components on a Yard Sport YS400. The first part is this pipe, which comes out of the exhaust port area or the cylinder. It looks like it had a piece of rubber hose on it, but the hose is gone, and I have no idea what it was previously connected to.

      The second item is this vacuum valve looking thing.  Again only one line is still attached.  What is it's function and what other lines should be connected to it?

      The last thing is this hose, which exits the side top of the fuel tank (not the fuel line hose) but is not connected to anything

       
      Any help the community could provide would be greatly appreciated.  This UTV belongs to a friend, and I am trying to help him get it running correctly for his kids.
    • By Stan Morton
      My 2018 XG-850-SL starter died yesterday. The old part number from Kubota is E7153-11732 which has been superceed by part # EG881-63010. I am looking for an aftermarket starter because the Kubota retail price for the starter starts at $550 and upwards toward $850.  If anyone has gone down this road before and has found an aftermarket starter ~ please share with me. We own a ranch and this thing is used every single day and is sorely missed when it is down for maintenance.  Kind Regards, ~ Stan
    • By Pop Bob
      After 10 hours of use, my machine had developed a low speed brake squeal. I removed the brake assembly and discovered that everything was put together dry. Not even lubrication on the caliper pins. After lubricating and reassembly, the squeal has disappeared. I will do the other three wheels today. Also, all grease fittings were under-greased (if at all) based on the amount of grease filled before they purged. This includes the drivelines. Next- I found many screws which were loose and/or stripped. I was able to tighten or fix them with my tap and die set. The lower a-arms on the front do not have grease zerks. I will remove the arms and install some. I guess I’m not surprised or even disappointed. These are just things that should be looked at on any machine. One thing I am pissed about though, is this “weld from hell” on the front . Totally unacceptable. For sure there will be water entry and eventual internal rust. 
      (see photo) I will fix it. I did an oil and filter change which some of you will say was not necessary. But break-in time is when you are most likely to have contamination from production and initial wear-in. BTW there was some metal in the filter. Cheap insurance to change often. Engine access is very difficult on this machine compared to other  models. You have to remove lots of stuff to get to it. But I still like the machine very much, and I’m having a ball with it. Future plans include lights, cab enclosure and heater. Winters are long in Northern Michigan. 
      PB
    • By Michael Wood
      I have a 2018 Massimo Buck 400 with 278 miles. 
      Having issues with my brakes. Took the buggy hunting and when I let my foot off the gas pedal it pulls without pressing on the brake. I looked and the pads on all 4 wheels are all toast. The E-Brake hasn’t been on since I have had it. I am guessing it may be a master cylinder issue because all 4 pads are gone. They all seem to have worn evenly that’s why I think the master cylinder. Just got the machine used from a older couple and they said it sat for some time in there pole barn. Possibly the brake lines? Calipers? I took one brake apart and when I depressed the caliper it didn’t stay. Any help is muck appreciated. 
    • By Pop Bob
      While adjusting my suspension, I noticed an unused two wire connector on each side just hanging loose. Anyone know what they are? Nothing in the manual about them. 
×
×
  • Create New...