Quantcast
Jump to content


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Pop Bob
      While adjusting my suspension, I noticed an unused two wire connector on each side just hanging loose. Anyone know what they are? Nothing in the manual about them. 
    • By Chile
      I have a 2018 Massimo 700 MSU with the Delphi MT05 ECU.
      I have seen an alternative ECU reset procedure that involves running the engine at WOT for 5 seconds in neutral and then shutting down while throttle still at WOT.  The articles include comments that the rev limiter will prevent engine overspeed ad attendant damage. 
      1. Is this actually a recommended procedure for restting the ECU on a 700 MSU?
      2. What is the rev limited maximum RPM for the 700 MSU?
      I initiated this procedure but when the RPM exceeded 6000 I immediately terminated the process. It simply seemed excessive to me to continue.
       
      Any and all responses are greatly appreciated.
       
      Chile
    • By Joe Breaux
      Everybody out riding? Awfully quiet here recently. It's so damn hot here .We expect 112 to 116 heat index tomorrow..getting too old for that heat.
    • By BernieG
      I could really use some help identifying some disconnected components on a Yard Sport YS400. The first part is this pipe, which comes out of the exhaust port area or the cylinder. It looks like it had a piece of rubber hose on it, but the hose is gone, and I have no idea what it was previously connected to.

      The second item is this vacuum valve looking thing.  Again only one line is still attached.  What is it's function and what other lines should be connected to it?

      The last thing is this hose, which exits the side top of the fuel tank (not the fuel line hose) but is not connected to anything

       
      Any help the community could provide would be greatly appreciated.  This UTV belongs to a friend, and I am trying to help him get it running correctly for his kids.
    • By Pop Bob
      After 10 hours of use, my machine had developed a low speed brake squeal. I removed the brake assembly and discovered that everything was put together dry. Not even lubrication on the caliper pins. After lubricating and reassembly, the squeal has disappeared. I will do the other three wheels today. Also, all grease fittings were under-greased (if at all) based on the amount of grease filled before they purged. This includes the drivelines. Next- I found many screws which were loose and/or stripped. I was able to tighten or fix them with my tap and die set. The lower a-arms on the front do not have grease zerks. I will remove the arms and install some. I guess I’m not surprised or even disappointed. These are just things that should be looked at on any machine. One thing I am pissed about though, is this “weld from hell” on the front . Totally unacceptable. For sure there will be water entry and eventual internal rust. 
      (see photo) I will fix it. I did an oil and filter change which some of you will say was not necessary. But break-in time is when you are most likely to have contamination from production and initial wear-in. BTW there was some metal in the filter. Cheap insurance to change often. Engine access is very difficult on this machine compared to other  models. You have to remove lots of stuff to get to it. But I still like the machine very much, and I’m having a ball with it. Future plans include lights, cab enclosure and heater. Winters are long in Northern Michigan. 
      PB
×
×
  • Create New...