Quantcast
Jump to content

Sign in to follow this  
UTVBoard News

Ricky Johnson Race Series Rumor Confirmed

Recommended Posts

Since the very successful race that Ricky Johnson hosted at the Perris Auto Speedway on November 8th there have been rumors of a series coming in 2009.  We have finally been able to confirm those rumors: There will be a 3 round Ricky Johnson Offroad Grand Prix.  All of the information that we have is [...]

View the full article

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Tomoto
      Hey folks. I recently acquired a pre-owned Hisun 500, carburated. And surprise... it has issues.
      When cold, it typically starts without any issues, but once it warms up it tends to sputter and stall out. When accelerating, you can also feel it hesitating occasionally, and when you stop or put her into reverse, she will often stall.  The fuel is clean, I installed a new fuel filter, and the air filter is clean. Though the fuel pump appears to be working ok, it makes a strange knocking sound whenever power is put to it.  I've never heard anything like it, and I'm not sure if its shot or just a cheap Chinese pump thing. I have an aftermarket pump coming, and I've ordered a new ignition coil as well on the off chance that it is faulty. I am hoping replacing these two parts will solve the issue,  and if it does I will post the results here. 
      If not, anyone have any other ideas?  Also, I've noticed it is very difficult to find parts for this make... any suggestions on a good source for Hisun parts? I appreciate any comments or insights. 
    • By Jimmy Bellagio
      I have a 2009 Trooper 2 that sat in garage in Vegas for 2 years and fuel wen bad.  I replaced the fuel filter, fuel pump and drained and put new fuel with stabil.  So here is where it gets good I am getting fuel to the pump, pump is making noise like it’s working but no fuel will come out.  Anyone else have this problem?  The only thing I can think of is that I had to put the old outlet on the new pump, I cleaned and blew it out best I could. I can’t use the one from the new pump due to it being threaded.   Any good suggestions?  I checked fuse and relay, I even hot wired the pump.







    • By bbbv4711
      New here and have a question.
      I have a 2009 Arctic Cat Prowler 1000, I am wondering if other year engines will work on the 09? Looking at part numbers the engine has the same part number for 09 and 10, then 11 to I believe 15 have a different part number.  When looking at rebuilt engines some one stated  that theirs would fit Prowler 1000 09-15. So I thought I would ask.    Thanks in advance
    • By nascarcamshaft
      I have a 2009 Trooper that when I first start it it runs great but after about a min it starts to cut out under acceleration but clears out when it gets revved up.  I downloaded the manual from   Joyner-usa.com   but it doesn't help much,  Mine doesn't have a OBD port on it and my son who is a mechanic said he can wire one in if we have a wiring diagram for the CPU but the wiring diagram of the CPU that is in the manual is for a 3 cylinder engine.  The manual talks about a MIL light that can flash out a code but I don't know where that is and even if I did find it they  don't tell me how to read it.  I have tried the coil and the map sensor and that didn't help I checked the TPS and it checks OK.  I emailed Joyner and all I got from them is there should be a OBD port on it and then they said they checked and found some don't have it,  No help from them. Anybody run into this problem or know were I can turn to get some help on this, even a good wiring diagram of the CPU would be a big help.
      Thanks for you help
    • By Whisper Snowbird
      Fuel pump runs but nothing is getting tô it. I tried putting a vacuum on the outlet hose of pump and it wouldn't pull anything. This machine sat for a year and a half unused. Is there a way to prime the lines?  What could be the cause of the fuel not getting tô the pump? 


×
×
  • Create New...