Quantcast
Jump to content

Rumble

Rumble on the ridge 2009 Adena Ohio

Recommended Posts

Rumble on the ridge of Adena Ohio would like to announce the dates for three events in 2009!!

MAY 2nd

JUNE 27th and JUNE 28th

SEPTEMBER 19th

New for 2009 the June 27th and 28th event will be an entire weekend of Riding & Camping!!!

For 2009 the cost will be for the May and September events will be the same as in the past. $20.00 for Adults, $15.00 for children 17yrs old and younger and camping will be $20.00 per vehicle. For the June 2 day event the cost will be $50.00 per person and this will include camping for both nights. Also we will allow one day riding on Sunday June 28th Only for $20.00 per rider. We will not allow one day riding at the reduced price on Saturday June 27th. Also we will have entertainment (DJ/band) and some organized events (Mud Bogs) planned for this weekend. Also you will receive a free ticket with admission for our ATV giveaway as in the past for each event. More details will be coming soon!!!

For more details about the Rumble on the ridge check out our website at www.rumbleontheridge.homestead.com

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Anthony Butler
      So my rear diff lock cable is seized on a 2009 trooper 1100 T2 . How do i remove the end that goes into the diff ? 
    • By Joel Goldsney
      2009 Hisun 700.... previous owner did a number of changes. This part is under the driver's seat but not attached  to anything.
      Is this the old fuel pump?
    • By Joel Goldsney
      Wasn't sure exactly how to title this thread as I have a few issues with my newly acquired hisun UTV. Hopefully going to consolidate all the issues in one thread. 
      I purchased from a guy who  had rebuilt the engine  replaced the fuel pump as well as re-done the front end. He had the unit running and driving when it quit and would not start. He got frustrated and decided no more projects and sold it to me.  Unit is in excellent condition physically.....hardly any scratches on the plastics. All in all its a good unit with the following issues/symptoms
      1) Mis fire and stalling out when revved
      Well as you can see by the title of the first issue I managed to get the unit running.  Seems that the battery was very weak. I charged the unit and it fired up fine.  The engine seems to stutter and misfire when revved and once the unit warms up it stalls out. I think it's a fuel issue as if I give it a shot of ether it starts back up.  
      Additional Note: Revving engine in Neutral  seems to cause indication to flicker and occasionally the reverse light comes on  which seems to kick in the reverse rev limiter. Have also hade this happen when driving around. Reverse Light flickers and revs get cut. 
      2) Fuel line configuration.
      When he replaced the fuel pump he got creative with the tubing and removed the "small fuel tank" 
      (See pictures)
      Not sure  what the purpose of this tank is but would love some pictures of a stock set up so I can  put everything back together correct.

       
      3) Issues engaging in gear
      The unit seems to have issues going in to gear...I will move the shifter in place  but the gear won't engage and the lights don't indicate correct. It takes a few tries to engage and sometimes it grinds a bit 
      4) Rack and pinion slipping
      This problem is probably a simple replacement fix...when turning to the right with the vehicle not moving the steering just slipps and turns without turning the tire. I believe I just need to replace the rack and pinion but if there is something else please let me know.
      Any insight or tips on resolving any of these issues would be much appreciated.
    • By Joel Goldsney
      Ok I am hoping things aren't totally pooches
      Side by side stalled out on my son and wouldnt start. Seemed to have very low vacuum draw on the pump and even when primed manually it wouldn't push much gas. 
      Have been wanting to check the valves any ways to see if they were off spec ( had been having issues with running rough)
      I checked the valves....intake seemed a little tight and the exhaust very tight ( exhaust were brutal to get to ) 
      Decided to check compression while I had the plug out....picked up a new compression tester as I couldn't find mine and was getting 0 compression.
      Seemed strange so I pulled the tester out and cranked it with no plug to see if I was getting air movement.  Seemed to be pushing air out of the plug hole fine....then heard a clunk sound and now the starter won't turn it over....it trys but it's like things are jammed.
      Any thoughts on how bad I have screwed up?
      I didn't think anything I did should have caused any damage. 
       
       
    • By dpostma
      I have a 2009 T2 joyner for sale, health and age issues have kind of sidelined me the past several years.  The joyner has been in inside storage and is in very good condition with less than 3 K miles.  I have made many mods from suspension to engine and frame.  I am asking $7K or best offer. If interested contact me via email ([email protected]) and I will supply additional detail information.



×
×
  • Create New...