Quantcast
Jump to content

Jimmy Bellagio

Members
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by Jimmy Bellagio

  1. Got it figured it out. It was the out-side port was still clogged. Fired right up. It has a one way flow control that was gummed up.
  2. Yes, I have fuel all the way to the pump, it has a larger inlet so it can’t be installed backwards. There is a black and red wire that goes to positive, so it is wired correctly, I even hot wired it. I’m going to go get new fuel lines, drain the fuel tank again and see if I switch the outlet to the one that came with the new pump to see if that’s the problem.
  3. I have a 2009 Trooper 2 that sat in garage in Vegas for 2 years and fuel wen bad. I replaced the fuel filter, fuel pump and drained and put new fuel with stabil. So here is where it gets good I am getting fuel to the pump, pump is making noise like it’s working but no fuel will come out. Anyone else have this problem? The only thing I can think of is that I had to put the old outlet on the new pump, I cleaned and blew it out best I could. I can’t use the one from the new pump due to it being threaded. Any good suggestions? I checked fuse and relay, I even hot wired the pump.
  4. Where are you located? I have a guy in Phoenix that is doing my rebuild. He is putting low comp pistons, turbo and a Ron Davis RAD in for me. Just part's with low comp. pistons and machine work is around $1,300.00. I know he has a few sources that he gets parts from. JCM, silver bullet motorsports. 30" Mud lights w/ ITP bead lock wheels King coil over's master craft seats crow 5 point harness custom paint Racing Pro comp lighting Up graded axels, Differentials, brakes 500W stereo custom front bumper top rack wish list for near future power steering Ridged LED light bars Roktane XD 32" tires reinforced roll cage w/ doors.
×
×
  • Create New...