Quantcast
Jump to content

Hopper

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Hopper

  • Rank
    Newbie

Profile Information

  • Gender
    Male
  • UTV Brand
    Joyner T-2 1100
  • Interests
    Outdoor riding, boating, Fishing, Hunting
  1. Hopper

    Hopper

  2. Ok I will check the grounds out thanks for your help!!!
  3. Trevor at Mudslinger motorsports is very knowledgable and seems to have the turbos dialed in.
  4. Hello everyone My username is Hopper I am new to this site and I was wondering if any of you could help me with a issue I had last ride. I had just moved my radiator up to the back box and replaced my starter on a test run it was running really well than all of a sudden it was like the key was shut off so I checked all the basic functions and could not get it to flash up. When I got back to my shop I had a look at the fuel system and was producing 50 # and had fue up to the fuel rail also checked coil for power and there was power at coil plug. A riding buddy had a T2 there that was in good running condition and I was able to swap out a few parts off to test On my T2 here is what I swapped out to check ECU unit, cam sensor,crank sensor, coil and had no luck getting it to start up I also pulled the plugs and they were dry and had no spark. I am not a mechanic but can figure most things out but this one has me confused if any of you have any input It would be appreciated. I am impressed with alot of the topics and knowledge that I have seen on the topics great site! Hopper


×
×
  • Create New...