Quantcast
Jump to content

Carolynski

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Carolynski

  • Rank
    Newbie
  • Location Baton Rouge, LA, USA
  1. Carolynski

    Carolynski

  2. Only if I put power directly to it then it will click. I guess it’s not getting power.
  3. Ug the new injector didn’t fix it. I suppose it’s not getting power. What does that mean?
  4. It did click and was pressurized but nothing came out. The fuel pump is new. I bought this for $500. It’s been sitting for like 6 years and so many many dummy’s have messed with it that things were out of sorts. I believe I’ve got ever in order again. It only has 23 miles on it. I ordered a new injector. Should be here in a couple days.
  5. I couldnt get a good read on the electrical plug because my leads are too big to touch the contacts but today I put 12 volts directly from the battery to the injector and it clicked but still didn’t spray. So there may still be a problem but regardless I guess I need a new injector anyway.
  6. I couldnt get a good read on the electrical plug because my leads are too big to touch the contacts but today I put 12 volts directly from the battery to the injector and it clicked but still didn’t spray. So there may still be a problem but regardless I guess I need a new injector anyway.
  7. Thanks y’all! I took the throttle off and felt inside the boot and it wasnt wet. I then removed the injector from the boot and turn the key on and nothing sprayed. idk how to test for voltage. I assume ground one lead and test one on the prongs for power?
  8. I have a Q-Link (Rhino clone) and the fuel injector won't open up and spray. The fuel pump is brand-new and kicks on and primes to the injector but nothing comes out. I've cleaned and dielectric greased the electrical plug and the ECU plugs but no change. not sure where to go from here. Any help?


×
×
  • Create New...