Quantcast
Jump to content

Sign in to follow this  
utvman

SXSA RHINO SHINES AT BITD RACE

Recommended Posts

The Side X Side Action Magazine Race Rhino participated in its fourth race this past weekend for the Best in the Desert Terribles’ Town 250 in Primm, Nevada. Beginning at sunrise, the car hit the starting line and ran better than ever before. The improved performance is a welcome change after blowing a [...]

View the full article

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Brad Collins
      My side by side always " struggles " when reaching 40 kph. Almost like there's a govender. I cleaned the carb and removed the filter. Always there. The machine was lit up for a couple of months. I still operate it, just at lower speeds. Any help would be greatly appreciated on the issue. Thanks for your time.
    • By Mark Popeye
      Hi,  Just purchased a 2010 Qlink Frontrunner 700.  Using it to plow my yard (just moved back to NH).  I knew it had starting issues but that was mostly around the starter relay (as shown, when I was looking at it).  I rewired (and soldered) the 4 wires that go to relay, replaced the relay, starter and battery.  It still starts extremely hard but runs great.  I don't know what else to check.  On another topic, which way do wheel hub nuts turn to loosen?  TIA.
    • By Mike Turner
      American SportWorks LM 650 won’t start at times. Starter won’t engage the solenoid just “clicks” much like a weak battery would cause. Battery was replaced and problem went away and then came back. Replaced positive battery terminal. Problem resolved then returned. Replaced negative battery terminal. Problem gone then returned. Replaced the positive and negative battery cable ends. Problem resolved and now returned. The repair lasts for maybe 12 starts, then the solenoid just “clicks” again as it will with a weak battery. So I replaced the ignition switch. Problem solved for a week. With each “fix” the problem is resolved but only temporarily. Does anyone have any suggestions ? To replace the starter is expensive especially if it’s not the problem. 
    • By Robbie Wyre
      I'm working on a 2005 Cub Cadet side by side and I'm trying to remove the front two axles.  I have a slide hammer puller on the inner joint and with all my strength they will not budge.   Anyone have the same issues and is there something I'm missing or a trick of some sort to pull these out?   Any suggestions please and thank you.
    • By DeWayne Stanley
      Got a new RTV XG850 Sidekick and wanted to know if anyone have any problems with theirs. 



×
×
  • Create New...