Quantcast
Jump to content

flyenj68

New Joyner Trooper Ring Gear and Pinnions

Recommended Posts

Ok guys I have found a source in China that shipped me a new front ring gear and pinion for my trooper! I am checking on the availability of the rear set right now. I am thinking about ordering a bulk shipment of front and rear sets and selling them on ebay. They would be around $275-$300 a piece, depending on what deal I can work out.I was just looking for some input on if you all think I could sell them,I would hate to spend the money and get suck with them. Here's a pic of the front I got and installed in my diff last night.post-2052-0-60644800-1418702011_thumb.jpgpost-2052-0-35386800-1418702043_thumb.jpg

  • Like 1

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Travis
      scared me all the way to death and back.
    • By cliffyk
      I had mentioned in a previous post that I had removed the front anti-roll bar from my 2020 Outfitter 400; I ran that way for a month or so without noticing any downside however recently I installed a 'suicide knob" (see below) to assist my Parkinson's disease affected arms in turning the beast--but after doing so i found that in the quicker, tighter turns the knob permitted the vehicle would nosedive a bit, dig in, and plow  on hard surfaces--not scary, but quite noticeably.
      So I put the bar back on. Then today I got about 1-1/2 miles down the main road on the nearby power lines, turned around and came home to take it off--with the bar on, at 25 to 30 MPH, the front-end of the beast jumped like rabbit at each bump in either wheel rut., for a nearly brutal and quite uncomfortable ride. the bar (20 mm solid steel) is far too robust for the weight of the vehicle. The front bar on my 3900 lb. Infinity M37 is 30 mm...
      suicide knob--for you younger folks:

    • By M C
      Hey guys just bought a 07 trooper. Previous owner stated it ran great etc prior to clutch job then had issues. I drained tank, replaced plugs etc. found one of the injectors connectors was not connected and plugged it in. Solid 50psi fuel pressure.  It starts easier than previously on 3 cylinders but still runs very very poorly. I’m thinking the sound I’m hearing is it detonating at around 3k. It kinda sputters and falls apart. Sounds like clicking or something when it happens. I am at a bit of a loss, compression is a solid 150psi across the board with no movement. Verified spark and now am assuming all injector are functioning more or less correct as if I unplug any one it sound terrible at idle. 
       
      A note, I tapped plugs at .7 manual called for .9-1.1 but that seems super over doing it but I will try adjusting them to 1.0
      additionally I’ve noticed the fan in rear doesn’t turn on. 
       
      anyone with any help I will be in your debt.
    • By ANIL SEDALI
      Hi friends. I'm Anıl. I live in Turkey. I have a Hisun 700 UTV 2015 Models. My problem is : 
      inability to change gear after the engine has started. Before the engine starts, it can shift into all gears; but after running, I cannot change gear. At about 3000 km. Fuel injection model. Can anyone help on this topic? Thank you!
    • By Chris Miller
      Good Morning Folks..Happy New Year, I have been having some intermittent issues with my 2015 American Landmaster LM500 not going into neutral. Seems if I shut the engine off it would pop into neutral. Yesterday I was splitting firewood with a 500 pound log splitter that I pushed to my wood area up a slight grade. I was not able to get it into neutral which I assumed was due to the pressure of the weight of the splitter pushing back. after I finished splitting wood, I used the weight of the splitter to roll back down the hill to my driveway. I unhooked the splitter but still could not get it to go into neutral or start. I dragged it back into my barn with my mower as I don't leave anything outside over night. I am at a loss what to check to try to fix this. I use my UTV (Eustas) every day that I am at my place where I keep it and will be lost without it. Thoughts? 
just get it
×
×
  • Create New...