Quantcast
Jump to content

Recommended Posts

Just bought a 2003 Polaris 1500 with a 650 governored motor.Am going to use for recreation & hunting.

How would I bypass the governor & run straight throttle?

Anything else that can be done to UTV to make better?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By johnpeter
      2020 Polaris RZR Turbo 4 On Ebay
      https://www.ebay.com/itm/2020-Polaris-RZR-Turbo-4/264951708256?

    • By johnpeter
      2017 polaris rzr xp 4 1000 eps - 608 miles On Ebay
      https://www.ebay.com/itm/Lifted-2017-polaris-rzr-xp-4-1000-eps-608-miles/333792067884?

    • By johnpeter
      2018 Polaris RZR 4 Turbo On Ebay
      https://www.ebay.com/itm/2018-Polaris-RZR-4-Turbo/164524898583?

    • By johnpeter
      2017 Polaris 1000 4 seater Turbo  On Ebay
      https://www.ebay.com/itm/2017-Polaris-1000-4-seater-Turbo/224228870318?

       
    • By Logan
      Ok so I have a Polaris ranger xp 08 I think . I started it up no problem( never had any ) drove it out of the garage about 15 feet and let it idle for about 5 mins . Then it started to sputter , gave it some gas and it stalled out. Tried to start it a couple times but wouldn’t go. I figured gas was low, put some in but same thing . So I got the ether and took the air filter off sprayed it in and it fired right up but would stall out instantly.  So I tried it again and gave it some gas but same thing . Next I just sprayed and jus got enough to gas it back into the garage . But then I saw flames coming out of the air intake . Was able to put it out quick ( 10 seconds) just by blowing on it . Before anyone says to much starting fluid I know a little goes a long way . I didn’t hold it down and jus spray , only a quick burst twice before stalling out . But where do I go from here ? Engine not getting enough gas ? But then why was I able to start/drive/ and idle at first ? Now I can’t even get it started . Let me know what you think.
  • Similar Tagged Content

    • By Alex
      You may have noticed some small updates to UTVBOARD. We have upgraded some of the software that runs this site.
      Any issues, please post them here.
      Updates include:
      Ability to comment on Status Updates
      Facebook and Twitter Login
      Facebook Like Button on Thread pages and new Social Network Icons
      Updated Chat Room with count of who is in chat, in main menu
      Archive Personal Conversations
      Mobile Phone Interface (In Progress)
      More moderation and behind the scenes updates.


×
×
  • Create New...