Quantcast
Jump to content

WebSerf

2006 Mule 610 starts, idles, but no power

Recommended Posts

I have an underused '06 Mule 610 with 275 hours on it that has been sitting too much. It starts just fine and idles with no missing or stalling but, when I try to accelerate, even with no load on level ground, it stumbles and won't go unless I use the choke. I haven't tried to take it out for a run because I'm not sure it will come home under it's own power but it does seem to run OK with the choke fully closed. I changed the fuel filter and checked the air filter but nothing else yet.

Share this post


Link to post
Share on other sites


Webserf

Your main jet is plugged up. Run Sea Foam in it and it may clear up. If not remove the carb bowl and float needle valve and use a needle or straight pin and clear the main jet.

Share this post


Link to post
Share on other sites

Sea Foam DID help but it did not completely solve the problem. The Mule would run after I cleaned the main jet but still had no power without the choke. I used the Sea Foam and it ran better but still needed the choke to run at low RPM's. I just got a call from the dealer I took it to and the carb had a part that needed replaced (in the float bowl?) and the 'pilot jet' needed cleaned. That service along with a belt replacement will cost $312.12. Thanks for the help. It did work but I had more problems than I knew.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By bjones
      2007 Mule 610,  owned for 8 yrs and valves were ticking when I got it and had them adjusted twice and this is when plugs began to foul.  I replaced battery (used battery I had on hand) a yr ago and didn't foul a plug for some time and replaced batter (new) with a bigger lawn mower type battery again a month ago and have fouled two plug since.  Had carb cleaned and valves adjusted and still fouls plugs way to often.  Friend has a mule just like mine and his does same thing. Have read this is a common problem with 610 mule.  Any help or suggestions would be welcomed.  Thanks and stay healthy.
    • By Travis
      View File Kawasaki Mule 550,520,500 Engine repair manual
      This file contains all specifications,troubleshooting and repair procedures for the FE290D  (9.5H.P,286cc) engine used in the  Mule 500,520 and 550 models.
      Topics covered include,  general information, service data, disassembly, reassembly,inspection of parts and maintenance.
      Notes:
      Make sure you're reading the correct information as this manual covers multiple FE series engine, some of which were not used in Mules, the manual does a very good job of clarifying which specifications and procedures are for which Model engine.
       
      Submitter Travis Submitted 01/13/2021 Category Kawasaki  
    • By IslandHopper
      Hi Everyone. I'd appreciate any thoughts on my situation. I'm an outdoor power equipment and compact tractor dealer. I'm interested in adding a line of UTV's. The problem I'm running into is that all the big names are taken in my area and the off-brands I've contacted sell for as much or more than the $8,995 entry level machines from Polaris, Honda, Kaw. etc..  So I'm considering going the pre-owned sales route. but are these new lower priced side x sides going to tank the used market? Thanks 
    • By Travis
      Hi, all, I am here to say i have found an excellent source for kawasaki parts, It's run by  Eddie Babbit. It is called Kawasaki Partshouse. run by Babbits online, Muskegon Michigan. http://www.kawasakipartshouse.com/oemparts
      Just the other day i ordered piston rings, for my Mule 550, They got here and a Oil ring, and smaller ring were missing from the box, Kawasaki took responsibility for the "Accident" and  I had also contacted babbits, and they replied and they said" keep the old rings, order a new set and you just pay shipping" so i got $30 piston rings for 8.95!!!? Free shipping on orders over $50!!!
       
    • By Travis
      Rear right tire blew out going down the gravel road the other day, tried plugging it, but it was on the sidewall and it kept tearing down the sidewall, (rear tires are probably 10 years old, at least), so i called the dealership here in town since  i knew they keep tires in stock.
      Employee:"thank you for calling pro powersports how can i help you"
      Me:"i need to check on a price for a rear tire, 01 mule 550 KAF300C5, tire size is 22x11-10"
      Employee"alright, hang on one sec"
      Me:"okay"
      Employee "$237 for 1 tire"
      Me :"thank you sir"
      *click*
      I found single tires on ebay and amazon and RM atv etc for about $70 or $80 shipping not included, so i ordered this set off amazon,
      https://www.amazon.com/gp/product/B08572QZKZ/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1
      supposed to  be here Tuesday,  I'll be sure to keep this thread updated  on how the tires do so maybe if someone else wants try this $50 a tire deal.


×
×
  • Create New...