Quantcast
Jump to content

choctaw

2007 kawasaki mule 610 4x4

Recommended Posts

Hey Guys and Gals

As stated above the problem I'm having with it is, when I put in 4 wheel High or Low it makes a popping sound when going. Hope someone can tell me what this is and it is a easy fix and expensive! It only has maybe 15 hrs on it. Thanks any and all help!

Tammie

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By ANIL SEDALI
      Hi friends. I'm Anıl. I live in Turkey. I have a Hisun 700 UTV 2015 Models. My problem is : 
      inability to change gear after the engine has started. Before the engine starts, it can shift into all gears; but after running, I cannot change gear. At about 3000 km. Fuel injection model. Can anyone help on this topic? Thank you!
    • By Jim Sabin
      I have a 2012 MSU 500 that recently was having an issue with the motor not starting,  I ended up reworking the ground wire at the fuel pump leads and now I have notice that when I switch to 4Wheel drive, it does not work. Any ideals what going on?
    • By Heath Herring
      I have a 2014 4010 trans 4x4 (KAF620REF). Are the rear left and right driveshaft assemblies the same part number? I ordered the two sections individually for the rear right & they are coming up too short in length. Possibly the wrong parts ordered by the dealer? Thanks in advance.
    • By UplandHunter
      I purchased a Massimo 550 T-Boss side by side a year ago and overall it works  alright. Recently, I pulled it on a utility trailer to a dog training site on the highway and the windshield broke in half while pulling it behind my F-250. Massimo states that they warn that driving over 55 mph could cause a problem. I understand that but it seems to me that any windshield that can't withstand wind speeds of 70 mph should not be installed on a modern ATV. Has anyone else had this problem?
      Utv photo.msg
    • By Waleygator
      New machine, tilt wheel won't "tilt" and I don't want to force anything.  Owner's manual says to pull pin, adjust, release pin in desired position.  I can feel the pin moving, but wheel won't lower.  Any suggestions instead of taking it all the way back to the dealer?  Thanks in advance...


×
×
  • Create New...